JoomlaBamboo is now part of JoomlArt Read more

Support Forum

  • Page:
  • 1

problems displaying video in banner

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

i am trying to use zentools2 in the banner position and have it display a video. i have allvideos installed and i have the plugin turned on.i tried linking via youtube, i tried uploading it to the server, i tried putting it in images/videos

none of these results in the video playing in the banner position.

not sure what i am missing

also i have it set to show video in the k2 item, i have it set to autoplay as well. i can preview in k2. additionally i would be happy loading it from the videos directory but using images says that option is not available. so how do i get the video to display?
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 388 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
fyi i tried slideshow, backstretch, grid and masonry. in grid and masonry it displays a line of truncated code but if i copy and paste it looks like it's all there. this is what i would expect if a plugin was not turned on but i checked multiple times and it is.
{mp4remote}images/videos/timelapse.mp4{/mp4remote}

joannegroulx.com/index.php
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 388 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
With the zentools2 module what options are you using to display content e.g. introtext, image etc

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45153 posts
  • 2098 Thanks
  • Karma: 604
The administrator has disabled public write access.
video is the option i have set to display and nothing else and it shows the correct script it seems but like the plugin is off but it isn't.

i checked that both zentools and allvideos was up to date. reinstalled both to be sure
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 388 posts
  • 8 Thanks
  • Karma: 2
Last Edit: 2 weeks 5 days ago by candyce.
The administrator has disabled public write access.
Hi

With the video being loaded via a plugin I don't think this will work with the video option

You would need to use iframes or change video to something like introtext and enable plugins

I'd try with iframes with and without sizes

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45153 posts
  • 2098 Thanks
  • Karma: 604
The administrator has disabled public write access.
i tried using the plugin code in introtext (youtube)m_5g_D_iP2s|600|450|1{/youtube}

i also tried an iframe in the introtext <iframe src=""></iframe>

in both cases it shows me the line of text and doesn't display the video. i went to source to add the iframe text and saved without going back to the editor screen and it displays nothing.
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 388 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
Hi Again

Joomla editors by default strip out the iframe code as a security risk
In the editor you need to enable the iframe option / code

I'll find the article I wrote on it
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45153 posts
  • 2098 Thanks
  • Karma: 604
The administrator has disabled public write access.
blog.joomlabamboo.com/how-to-joomla/5-common-problems

covers it for the default editor and jce

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45153 posts
  • 2098 Thanks
  • Karma: 604
The administrator has disabled public write access.
The following user(s) said Thank You: candyce

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers