Must Read: New Unified System is officially live Must Read     |   11 Templates & 4 Extensions Updated Read more

Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Zentools2 "Random" not loading randomly pictures?

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hello!
I don't know if it's me not understanding how to configure the "Random" option in Zentools2 but it doesn't work.

See my settings:
prntscr.com/e6kfso
prntscr.com/e6mup5

I tested it locally by creating 16 numbered squares (prntscr.com/e6mrte and prntscr.com/e6ms30). I actually expected that when reloading the page, Zentools2 would reload some other images, using 9 of them in a random order. But this does not happen!

Zentools2 loads nine images and just changes the place where they appear. In this example, it loads the squares with the numbers 1-2 and 10 - 16. It will remain on this images even if another browser loads the page. See
drive.google.com/file/d/0B4mg0pGFgMnTd3RBb3MtU1JCUlE/view
for reference.

This isn't a random behavior I would expect when there are more than 9 images to choose from.

Please advise how to implement the correct random loading of images.
  • X-Bit's Avatar
  • X-Bit
  • 12 Month basic
  • 47 posts
  • 1 Thanks
  • Karma: 0
Last Edit: 1 year 2 months ago by X-Bit.
The administrator has disabled public write access.
Hi There,

I can't access the video

What is the content source you are using?

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hello Paul,
Sorry, it really didn't work with the aforementioned link. Please try
drive.google.com/file/d/0B4mg0pGFgMnTTEVUVWlDTjJsVGM/view
Instead.
Please note that I reloaded the site with Ctrl+F5 which should empty the cache and, as I am trying this now already some days, Zentools always (no exception) loads the same boxes!

You may as well download the clip to your computer: prntscr.com/e6yiwx

Original file video format would be .webm

Thanks for your appreciated help!
  • X-Bit's Avatar
  • X-Bit
  • 12 Month basic
  • 47 posts
  • 1 Thanks
  • Karma: 0
Last Edit: 1 year 2 months ago by X-Bit.
The administrator has disabled public write access.
Thanks

What is the content source you are using?

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Paul,
I really don't understand your question... please explain what you understand with "content source".

Sorry, I am not native English speaking.
  • X-Bit's Avatar
  • X-Bit
  • 12 Month basic
  • 47 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
No problem

Where are you loading the image content from?

Folders, Joomla etc
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
zentools2.joomlabamboo.com/zentools2-documentation

Down the left sidebar - "content sources"

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Oh, I see... I use the original directory "/images/one-page-grid" which has been used for the demo page: prntscr.com/e6zl8f

EDIT: I made a copy of the live site and put it on the subdomain. You may see the problem on kva.mcm-swiss.net live. Please bear in mind, there are 16 images (all numbered sequentially) in the "/images/one-page-grid" directory. Hope this helps to understand the problem. Even after the new setup and copying the numbered squares, Zentools2 still shows the exact same numbers!

Feel free to login (see credentials at the two open tickets) and try it out for yourself. Any changes made I need to get the know, as I will have to transfer it to the live site.
  • X-Bit's Avatar
  • X-Bit
  • 12 Month basic
  • 47 posts
  • 1 Thanks
  • Karma: 0
Last Edit: 1 year 2 months ago by X-Bit.
The administrator has disabled public write access.
sort-order.jpg


Does this work better for you?

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Rob... thanks a bunch!
This works like a charm...

Keep the good work up.
  • X-Bit's Avatar
  • X-Bit
  • 12 Month basic
  • 47 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
You're welcome

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers