Must Read: New Unified System is officially live Must Read     |   6 Templates Updated (27 April 2018) Read more

Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Menu not showing on home page for smart phones

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

I thought I posted this, but it's not showing up . . . so here it is again:

The menu options for my website (www.west-fly-fishing.com) do not appear on the home page when viewed from a smart phone. They appear on tablets and big screens, but not on a phone. All other pages correctly show the menu options on a smart phone.

Apparently I accidentally clicked some setting or other, because this used to work fine.

Can you point me in the right direction?
  • Scott Richmond's Avatar
  • Scott Richmond
  • 12 Month basic
  • 50 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Scott,

Are you sure this works on tablets?

Trying this on an emulator and I can't see a mobile menu

What is supposed to display on the mobile menu wise?

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hey, Paul!

On my iPad it shows the menu items horizontally, same as on a large screen except it wraps. This is true for all pages.

On my iPhone it shows the menu in a rolling option line on all pages except the Home page, where it shows no menu at all. For example, if you go to www.west-fly-fishing.com/index.php/fly-patterns you get the menu line, but you don't for the Home page.
  • Scott Richmond's Avatar
  • Scott Richmond
  • 12 Month basic
  • 50 posts
  • Karma: 0
The administrator has disabled public write access.
Ah ok so you have no mobile option for tablets

Are you using the same template style for home and other pages?
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
That is the intent. And how I thought I had it set up.

Where do I look to see if I accidentally changed it?
  • Scott Richmond's Avatar
  • Scott Richmond
  • 12 Month basic
  • 50 posts
  • Karma: 0
The administrator has disabled public write access.
Well you can tell with the template style if only one is assigned to live site pages by checking assignment tabs in template styles

or you can check the home link to see what template style is assigned to it
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
What do you have enabled in the layout > Collapse Menu?
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
In this section

2017-07-27_14h35_57.png
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Layout/Collapse and breakpoints:
ScreenShot2017-07-27at7.37.10AM.png


ScreenShot2017-07-27at7.37.36AM.png
  • Scott Richmond's Avatar
  • Scott Richmond
  • 12 Month basic
  • 50 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Scott,

What row is the select menu on?

Can you also check the responsive section of that row?

2017-07-27_19h15_06.png
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
It is in the Menu row (10). Response control is set to:

ScreenShot2017-07-27at3.14.39PM.png
  • Scott Richmond's Avatar
  • Scott Richmond
  • 12 Month basic
  • 50 posts
  • Karma: 0
The administrator has disabled public write access.
Hi There,

I can see a select menu on my desktop when I test resizing and on emulator

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I'm not getting it on Firefox or Safari in developer mode. On pages other than Home, I get the select menu on my phone but not in the emulator.

I also tried this on Chrome on someone else's non-apple phone and got the same results I'm seeing.
  • Scott Richmond's Avatar
  • Scott Richmond
  • 12 Month basic
  • 50 posts
  • Karma: 0
The administrator has disabled public write access.
hmm on my phone I don't see the menu on the home page

You do also seem to have table problems on mobiles e.g. extend off the page

Do you only have one template style assigned to the site?
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
It's really quite bizarre.
--If I select "Stacked" as an option for the collapsed menu, I get the menu on the home page. Yeah! Unfortunately it doesn't work. Sigh! If there are sub-menus, they won't show, and selecting the main menu item results in nothing. The only time it works is if there are no sub menus.
--If I select "Select" as an option for the collapsed menu, it works beautifully--except on the Home page
--If I select "Tag" as an option, nothing happens.
--When in "developer/responsive" mode for a browser, menus do not appear for the phone options. In real life, however, they are present (except for the home page).
--This used to work for the home page.

I should have only one template assigned for all pages. At this point I'm so befuddled that I'm not sure where to check the assignments.

I'm aware of the table problem. It's annoying, and I have no idea why that is happening; if you have an idea, please let me know. But it's not as critical as the menu problem, which is a top priority for me.

I may be confused about how to set the "Collapse" parameters. I thought I understood it, but now I'm not so sure. Could that be a source of the problems I'm seeing?
  • Scott Richmond's Avatar
  • Scott Richmond
  • 12 Month basic
  • 50 posts
  • Karma: 0
The administrator has disabled public write access.
Have you tried any other mobile menu options? - I appreciate that you have a lot of content to display
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
With the tables have you tried any media queries to reduce the padding?

Bit hard to be exact as it is a little trial and error but something like

@media (max-width:620px) {
table td {padding: 8px 2px ;}
}
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I will try the table query and see if that works. I also have some thoughts for other things to try on the Home page.

I am traveling for the next three days and will not be able to try anything until I return. Please don't take my non-response as a lack of interest! This is a very important issue for me!
  • Scott Richmond's Avatar
  • Scott Richmond
  • 12 Month basic
  • 50 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Scoot,

Best of look with the traveling

Please get back to us when you are ready

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Back home and able to work on this problem again . . . .

I have tracked down a piece of code that is causing problems. It's this snippet here:

<script src="ajax.googleapis.com/ajax/libs/jquery/3.2.1/jquery.min.js"></script>
<script src="ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/jquery-ui.min.js"></script>

When removed, the menus show up correctly on a smart phone. When left in, they don't. So apparently it is loading in a library that somehow tromps on the Buildr code.

Unfortunately that code snippet is necessary to make some custom features work properly on the page.

Is there a way to handle this so that I get both the menus to work and the custom code?
  • Scott Richmond's Avatar
  • Scott Richmond
  • 12 Month basic
  • 50 posts
  • Karma: 0
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers