Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

how to set different images for background if possible?

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi there,

I would like to have different background images in the top template area.

1) I cloned the template, changed the menu association, set a new image and saved it.
2) It seems that it does not work and the background also changed for the first template?

Do I have to change something else as I think copied templates work independently? How could I realize my planned set-up?

Thanks a lot!
  • MaMuster's Avatar
  • MaMuster
  • LIfetime Developer - Big Bamboo
  • 329 posts
  • 10 Thanks
  • Karma: 4
Last Edit: 5 years 9 months ago by MaMuster. Reason: forgot one information
The administrator has disabled public write access.
Hi

Are we looking at the background texture?

As I've just tested this and it works for me

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

I mean the picture I can assigne in the template backend under background. In the demo it is the picture with the trees.

I would like to have e.g. the tree picture for the home menu and e.g. for Joomla the Joomla banner.

If this is what you refer to as background texture, what are the steps that made it work for you?

Thanks a lot
  • MaMuster's Avatar
  • MaMuster
  • LIfetime Developer - Big Bamboo
  • 329 posts
  • 10 Thanks
  • Karma: 4
The administrator has disabled public write access.
Hi,

Themes and layouts are shared between different template styles.

If you have 2 template styles using the same theme and layout then changing the option in one theme will also change the option in the other.

So you need to create 2 themes, with different images selected. Use one theme in the template style assigned to the homepage and the other theme in the default template.

Regards,

Rob
  • Robert Went's Avatar
  • Robert Went
  • Moderator
  • 2210 posts
  • 196 Thanks
  • Karma: 90
The administrator has disabled public write access.
Hi Rob,

is creating two themes the same as cloning a template?

If not, can you give me a hint?

Thanks a lot
  • MaMuster's Avatar
  • MaMuster
  • LIfetime Developer - Big Bamboo
  • 329 posts
  • 10 Thanks
  • Karma: 4
The administrator has disabled public write access.
Hi,

Sorry, I knew that might sound confusing as I wrote it :)

Cloning a template creates a new template style which can be assigned to different menu items.

Within a zengrid 4 template, you have the option to create different themes and layouts.

The themes and layouts created within the template settings can be used by different 'template styles' so you don't need to reconfigure everything when you create a new one.

You can read about themes here: docs.joomlabamboo.com/zen-grid-framework-4/theme

In the theme panel for one of the temnplate styles (eg, the one assigned to the homepage), change the background image in the dropdown, then in the text field for the theme name near the red compile button at the top of the page, type a new theme name eg 'theme-homepage'.
Then when you save the settings you will create a new theme for that template style.

Regards,

Rob
  • Robert Went's Avatar
  • Robert Went
  • Moderator
  • 2210 posts
  • 196 Thanks
  • Karma: 90
The administrator has disabled public write access.
Ok, thanks.

It is a bit confusing and maybe you consider making it easier if possible. With your help I got it to work.

Now I have a new problem: I saved the standard template with a new name. I apply it to one menu item. I go to the theme settings and select green instead of blue and give it a new name, too. Then I compile the CSS. Works fine. I can even see the site in the new style.

Once I save and exit, it is all back to the standard theme.

What am I missing? Is there a max number of themes I can compile to CSS as I have many of them?

Update: The page in question with the copied template is not displaying correctly, 1/3rd of the CSS seems to be missing. seminar.de.w00d0e9a.kasserver.com/index.php/seminare/wirtschaft-2030-i-entscheider-fach-und-fuehrungskraefte

thanks a lot
  • MaMuster's Avatar
  • MaMuster
  • LIfetime Developer - Big Bamboo
  • 329 posts
  • 10 Thanks
  • Karma: 4
Last Edit: 5 years 9 months ago by MaMuster. Reason: Update on the problem
The administrator has disabled public write access.
Do you see any error when trying to compile the theme not working?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Are you adding any spaces or special characters to the template style/theme?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Fast as always :)

a) No, I do not see an error, just the other way around it confirms me, that all went well.

b) Yes: I named the template styles and the themes the following way
corporation - Background Menu1 and
blue - Menu1
... etc. ... So I have empty spaces and a dash, not sure if it counts as special character

So far it worked.

best regards


best regards
  • MaMuster's Avatar
  • MaMuster
  • LIfetime Developer - Big Bamboo
  • 329 posts
  • 10 Thanks
  • Karma: 4
Last Edit: 5 years 9 months ago by MaMuster. Reason: missing letter
The administrator has disabled public write access.
yes I think that would break it using -

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Ok, I just tried it again.

a) Should I name the copies of the template without space and - , too?

b) I just did a new copy of the standard template and them. I then changed the theme to green first with adding the name with an underscore green_XXX, then without any addition just green and also greenXXX?
I have the same effect. I can the the style applied, but not save it. It also does not show up in the theme selection dropdown.

Any other idea?
  • MaMuster's Avatar
  • MaMuster
  • LIfetime Developer - Big Bamboo
  • 329 posts
  • 10 Thanks
  • Karma: 4
The administrator has disabled public write access.
How big is the image you are adding file size wise?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
For the theme green, I did not attache an image yet. Theme blues (included in the original I do the copy for the template from) has 150kb.
  • MaMuster's Avatar
  • MaMuster
  • LIfetime Developer - Big Bamboo
  • 329 posts
  • 10 Thanks
  • Karma: 4
The administrator has disabled public write access.
so this template on this page breaks if you add the image and works once its removed?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Well, not exactly.

I never got so far. I set row6 from full-width to inherit and had no picture in the background as I still have to upload it.

After you last post I checked for a picture in the background. There was none and the field was empty. So, I first set the background image to inherit -> my row style changes where not saved, nor the theme (as far as I remember).

Then I tried with adding a picture. Not only is the theme (green) now saved and applied, also the row styles are now correct and saved.

In conclusion, now it works, but do not ask how and why. Also the steps in the setup I did take (clone template, create new style, change settings) did not differ.

cheers
  • MaMuster's Avatar
  • MaMuster
  • LIfetime Developer - Big Bamboo
  • 329 posts
  • 10 Thanks
  • Karma: 4
The administrator has disabled public write access.
Right - could be there was an empty field that you filled with a setting

so in summary all ok now in this thread?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers