Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Ascent2 - Banner issue

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi.

I’m having a problem with the banner on the new Ascent2 template:
www.itloftet.com/stk/index.php

I’m using K2 as content source and Zentools2. The slideshow is showing a blank page as the first image. Any suggestions? Does not seem like the auto play function is working either.

BR.
Paul
  • itloftet's Avatar
  • itloftet
  • LIfetime Developer - Big Bamboo
  • 21 posts
  • Karma: 0
The administrator has disabled public write access.
Hi

There does not appear to be an image in the first K2 referenced by zentools, you could check all items called have images in K2.

For the autostart, worth checking zentools setup again for the slideshow.

Regards Ian
  • iafdesign's Avatar
  • iafdesign
  • LIfetime Developer - Big Bamboo
  • 393 posts
  • 153 Thanks
  • Karma: 58
The administrator has disabled public write access.
Thanks Ian :)

Also possible you don't have image selected to show

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi. I Think found the problem. The zentools module was set to show only featured items. I had two features items but the gallery was showing three items. Does not seem like the show only featured items is working.
  • itloftet's Avatar
  • itloftet
  • LIfetime Developer - Big Bamboo
  • 21 posts
  • Karma: 0
The administrator has disabled public write access.
Hi

Was this with the latest module version? as it is working ok for me

How many categories are you selecting from? - it is the backstretch slideshow layout you are using?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I have a new banner issue with Ascent2. Only concerns the homepage. www.deliciousitaly.com

Worked perfectly until after activating Dynamic Cache via Siteground. Then it became blank.

Changing the Slideshow module settings (to disable javascript) seems to have resolved it in Chrome but Safari remains blank.

Help appreciated as the menu is inaccesible for ios users as things are as described above.

Philip
  • Philip's Avatar
  • Philip
  • 12 Month basic
  • 272 posts
  • 4 Thanks
  • Karma: 4
The administrator has disabled public write access.
UPDATE: we removed one Zentools2 module from the homepage, enabled javascript settings for the Slideshow, and disabled them for the 'Recommended Restaurants' module.

Seems ok now, but would like your take on it. I remember when we first set up Ascent2 we had the same problem with the homepage and had to play with the javascript settings of the Zentools2 modules until we found a combination which allowed everything to be visible.
  • Philip's Avatar
  • Philip
  • 12 Month basic
  • 272 posts
  • 4 Thanks
  • Karma: 4
The administrator has disabled public write access.
Caching is a challenge

Are you referring to the plugin extension download from siteground?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
indeed SGCache. Homepage slideshow gone blank again in both chrome and ios
  • Philip's Avatar
  • Philip
  • 12 Month basic
  • 272 posts
  • 4 Thanks
  • Karma: 4
The administrator has disabled public write access.
Not sure if this is a solution:

"The Dynamic Cache interface allows you to flush the cache only for certain applications. For example, if you have a Joomla! CMS installed in a /joomla sub-folder and Dynamic Cache is enabled for it you can flush the cache only for this particular app. To do it click the "Flush Cache" button next to the application"
  • Philip's Avatar
  • Philip
  • 12 Month basic
  • 272 posts
  • 4 Thanks
  • Karma: 4
The administrator has disabled public write access.
or maybe this is the one:

How to Exclude URLs From Being Cached

jSGCache plugin provides an exclude list called "URL blacklist". It allows you to exclude specific URLs from being cached. This feature is really useful if there is part of your site or menu that have a lot of dynamic content and the page should not be stored in cache. In order to add an URL to the "blacklist", enter only the relative part of URL into the exclude list and hit the "Save" or "Save & Close" button.

For example if you want to exclude the:

www.domain.com/index.php/component/tags/tag/2-joomla
you should enter only:

component/tags/tag/2-joomla
  • Philip's Avatar
  • Philip
  • 12 Month basic
  • 272 posts
  • 4 Thanks
  • Karma: 4
The administrator has disabled public write access.
For me and what I've seen on this forum this extension is problematic if using dynamic content

If you really want to use a cache extension I'd look at jch optimise but as with all caching extensions they do need a lot of tweaking and testing
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
www.jch-optimize.net/

There is a free and a pro version

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Paul, read this in Joomla Issues Tracker. Basically turn global cache of in Joomla?

"Here is what began happening to one of my sites since I updated to Joomla 3.70. The page content is blank except all the menus and template styling. This site is on SiteGround and uses the JSGCache plugin. This happens when global configuration is set to Conservative Caching (type = file not memcached). System - Page Cache plugin is disabled. Using shlib - Db query cache and programming library plugin with memcached. Using SH404SEF and this is ordered just before the JSGCache supercacher plugin. To replicate just turn the Global Config cache to Conservative. Load a few pages, eventually the content will go blank. Turn the cache off in global config, clear the Joomla cache (not touching Siteground supercacher), isssue goes away. This site is using a Yootheme template and it is completely up to date. PHP7.1, everything up to date".
  • Philip's Avatar
  • Philip
  • 12 Month basic
  • 272 posts
  • 4 Thanks
  • Karma: 4
The administrator has disabled public write access.
Paul, I'm not going to consider JCOptimize. It looks too complicated. We have to remove a lot of settings active on the server. I'm not going to touch it.

What about excluding the homepage slideshow via the jSGCache plugin. What would be the correct path to add in the fields?

eg ".com/component/tags/tag/2-joomla"
  • Philip's Avatar
  • Philip
  • 12 Month basic
  • 272 posts
  • 4 Thanks
  • Karma: 4
The administrator has disabled public write access.
Joomla did have an issue with global caching in 3.7.0 / 3.7.1

I'd disable global caching if still using 3.7.0

3.7.3 is the latest Joomla version but I'd disable global caching to see if that fixes any problems first
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
ok, tks. I'll keep ypu posted
  • Philip's Avatar
  • Philip
  • 12 Month basic
  • 272 posts
  • 4 Thanks
  • Karma: 4
The administrator has disabled public write access.
best of luck
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Paul, System cache is off and Memcached set up correctly.

Siteground have suggested I get in touch with the extension maker after checking everything out.

So wondering if my version of Zentools2 is the problem? In fact its 2.3.2 not 2.3.3

2.3.3. changelog reads "Fixes compatibillity issue for php 7.1 and images from a folder source" Maybe this will work?

The pattern is: No slideshow images visible; make any changes in the backend & slideshow images appear; wait a couple of hours and slideshow disappears; repeat process.
  • Philip's Avatar
  • Philip
  • 12 Month basic
  • 272 posts
  • 4 Thanks
  • Karma: 4
Last Edit: 3 years 7 months ago by Philip.
The administrator has disabled public write access.
I've turned off the jsgcache plugin and slideshows is back.

There are three level of caching proposed by SuperCacher in Siteground. If Dynamic Cache Option is Level 2 and Memcached Level 3, thrn my logic says that we only need the Level 3 at this point. Is this correct thinking?

tks Philip
  • Philip's Avatar
  • Philip
  • 12 Month basic
  • 272 posts
  • 4 Thanks
  • Karma: 4
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers