Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Default template doesn't seem to be loading

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Let me just start off saying that I am sure it's *me* that has gotten something misconfigured :pinch:

On the below dev site, when you click on of the readmore buttons in the ZT module in the search area, the site merely loads an empty version of the home page (onepage) rather than the subpage template. I'm sure I've messed up something in the menu system somewhere (as evidenced by the fact that clicking on the logo does nothing). Other than this, I'm ready to show the client. Thoughts?

--> dev link <--

edit: to that end, I created a hidden link and hit it directly. This is NOT the template I set up as default....but a) it confirms I've gotten something messed up, and 2) i'll figure out what this template is and configure as needed. :blink:

Though if you have thoughts that will make this easier, I'm open to ideas.
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
Last Edit: 5 years 11 months ago by blueshift.
The administrator has disabled public write access.
Yep does sound like itemid issue

The logo may be a glitch in the sample data

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I linked the logo url manually. should I just create a new one? EDIT: yes. That worked.
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
Last Edit: 5 years 11 months ago by blueshift.
The administrator has disabled public write access.
Can I solve the ZT2 page link without creating menu items? This site could have hundreds of these.... or is there a way to create them automatically? I'd consider K2 but it hasn;t been updated in a very long time, and v3 is way, way past every date promised.
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
The administrator has disabled public write access.
As you say K2 is in the process of being updated to K2 v3.0 - just in case you've not seen this

getk2.org/blog/2460-k2-v30-to-be-officially-unveiled-in-joomladay-brasil-2015

Few nuggets in here you may want to read about
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
It's been being updated for a very long time now, for over a year at this point. I tried the beta, and found screen-clogging UI to be difficult to work with, and didn;t other wise see much new in it. Meanwhile, the production version suffers from bad documentation, no recent updates, iffy forum support (when there is any), missed deadlines.... I can't take my clients in that direction.

JDay Brazil came and went a month ago.....
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
Last Edit: 5 years 11 months ago by blueshift.
The administrator has disabled public write access.
Right fair enough :)

I've not properly looked at it yet

I think the pro option is aimed at providing paid support as support/documentation for a free product is hard and expensive to do
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Anyway content wise are you able to create the categories that the articles are going to go in?

If so you could create just the category links and that would solve the itemid issue - although that does give reduced flexibility assignment wise
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I've been less than thrilled with Joomla's category layouts....
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
The administrator has disabled public write access.
Yep but with the hidden menu you don't need them to display - just exist on the system

You wouldn't need to publish the page as such on the webiste
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers