Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

sticky nav not sticky

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

I thought I would borrow medica and see if i can take over from another build, so Medica here is not from quickstart. The sticky nav isn't behaving as expected... can you spot the issue from down under (or across the pond)?

--> dev link <--

unstickynav.jpg
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
Last Edit: 5 years 11 months ago by blueshift.
The administrator has disabled public write access.
Looks to me like one div is supposed to replace another - and that is definitely not happening.

this doesn't seem right either.

doesnt-look-right-either.jpg
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
Last Edit: 5 years 11 months ago by blueshift.
The administrator has disabled public write access.
At the moment I can see no height value being applied to the sticky nav

"I thought I would borrow medica and see if i can take over from another build,"

Not quite sure what this means - have you taken files from an other site using the same template?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
With the readmore are you using the custom readmore or just bog standard one?

With the sticky there is a js error in the zentools module which is also loading rokbox

So I would try disabling zentools grid1 and rokbox plugin to see if that is an issue

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I'm working from the quickstart on localhost. Getting what I want - just have to remove the demo data. the rokbox is just a modal thing and works fine in the quickstart.

my take is that i couldn't install medica as a replacement template.

No major worries with it going backward from quickstart. (I did need to reinstall ZT2, though.).
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
The administrator has disabled public write access.
Front page looks and works the way I want. Complete bafflement when it comes to loading a content subpage. For example, go to 'Recent' in the menu, click any item, and... scratch your head.

One page on front - but the result (and the search result) should go to a content page with maybe one menu item (Back to Home, or something). Clicking the logo doesn't work...can't get the one page menu off the sub page, it keeps loading onepage not the sub page default. So I am missing something here? (it's late - going to take the rest of the night off.)

--> dev link <--

Edit - the functionality i'm looking for his here, on another test site --> link <--

Edit - I removed 'recent,' use the 'search' tab instead (or go to the div below the banner).
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
Last Edit: 5 years 11 months ago by blueshift.
The administrator has disabled public write access.
The logo is a glitch with the sample data it is missing a link to the home page so its reloading the same page - try manually pointing using a menu likn

With the search results - you would need to create a search results page and point the search module to that link

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Logo is disappearing on the scrollout... odd. Seems like the same code should work on that div?

--> offending page <--
Attachments:
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
Last Edit: 5 years 11 months ago by blueshift.
The administrator has disabled public write access.
If you change the custom.css line 15 so it reads

.fixed #logo p {
display: inherit;
}

Does that work with the logo?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
It doesn't.

neither does outbound social to FB when sharing is off.


social---um-no_2015-10-07.jpg
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
The administrator has disabled public write access.
CORRECTION it DOES work with a .fixed in front
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
The administrator has disabled public write access.
Right so outstanding issue is the facebook link?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Assuming i can get the front page grid items to end up on the search page... getting search there should be no problem.

Edit: ZT2 links now land on correct page.

So getting there.... two medica production sites in the first month.
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
Last Edit: 5 years 11 months ago by blueshift.
The administrator has disabled public write access.
With a search results page can you not add them to that menu link?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I'm good now. It's all going to work - i have a problem with nn-tabs (first one comes up blank) but i've asked about this in *their* forum

--> link <--

Peter @ NN says its "caused by conflicting styles in the templates stylesheets (Zend framework): menu.less." I'm guessing I can solve this by adding my own class(es) to the tabs.
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
Last Edit: 5 years 11 months ago by blueshift.
The administrator has disabled public write access.
Thanks for the update

Good luck with it

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers