Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Problems with template behaviour Gazetta

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi
First adventure with JB so please bear with me!

Having loaded just the quick start package I change the font, compile and save and the banner and aside positions spread across the page. I changed the font back still the same problem. I checked all the template settings and all were exactly as in your documentation.

Spotted that the quick start is version 1.0 and that you've updated the template to 1.1 so I updated it. Also updated Zen tools to the latest version as that too was an older version in the quick start package. Eventually found that the banner row in the layout said full width. I changed that to inherit and got the template to behave again. (It does say Full Width in your settings doc so I don't know whether inherit is correct).

However, I'm still having problems when saving a new setting it occasionally repeats this and I have to reset it.

After the update I found that the Featured module in the aside position had lost it's primary background colour to the h3 heading. I thought that may be because your updates were done with the latest Joomla update so I've updated that and checked all settings again but can't find anywhere to sort that out in the framework or setting docs.

I am using admin tools but have tried uninstalling that and reverting to the default htaccess. No change.

1. Can you tell me what the default settings are on the featured module and where I can make changes to get the background to the heading back?

2. Is your documentation correct in the banner row being full width and if not is my setting of inherit correct or should it be something else? I tried using primary row but that just gets me a full width row of colour.

3. Has anyone else experienced problems with settings changing on save?

Hopefully, I have done something simple to the more experienced and that you can help me put my fundamental mistakes right.

On the plus side I'm at least going through all the settings and becoming familiar with what's there which is very much more than I thought!
  • Janice Jones's Avatar
  • Janice Jones
  • LIfetime Developer - Big Bamboo
  • 124 posts
  • 5 Thanks
  • Karma: 0
Last Edit: 5 years 11 months ago by manh.
The administrator has disabled public write access.
Hi

I'm looking at point 3 -

What is the memory limit on the site?
Do you still have admin tools uninstalled?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul - That was quick!
The memory limit is 120M. No. It made no difference so I put it back on.
Thanks. Appreciate your help.
  • Janice Jones's Avatar
  • Janice Jones
  • LIfetime Developer - Big Bamboo
  • 124 posts
  • 5 Thanks
  • Karma: 0
The administrator has disabled public write access.
Can you leave it uninstalled for now

If you have the browser console open during save do you see any error?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Ok. No. No error at all
  • Janice Jones's Avatar
  • Janice Jones
  • LIfetime Developer - Big Bamboo
  • 124 posts
  • 5 Thanks
  • Karma: 0
The administrator has disabled public write access.
Yes just checked it again. Akeeba uninstalled completely. No admintools htaccess. Changed the theme - banner full size. Changed it back Stil banner full size and the setting had changed in the rows again. Still no background to the aside module. No errors reported in the console.
  • Janice Jones's Avatar
  • Janice Jones
  • LIfetime Developer - Big Bamboo
  • 124 posts
  • 5 Thanks
  • Karma: 0
The administrator has disabled public write access.
Hi

Can you create a ticket and we can take a look - please include a summary of the issue and a pointer to this thread

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Thanks Paul
  • Janice Jones's Avatar
  • Janice Jones
  • LIfetime Developer - Big Bamboo
  • 124 posts
  • 5 Thanks
  • Karma: 0
The administrator has disabled public write access.
Thanks

I can see Rob has replied

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Yes Paul . He said that I needed to be logged in on the front end for the theme to compile correctly. I saw that in the docs. I was logged in. I had to be to see the pages! I also tried taking the site off line. It made no difference.
  • Janice Jones's Avatar
  • Janice Jones
  • LIfetime Developer - Big Bamboo
  • 124 posts
  • 5 Thanks
  • Karma: 0
The administrator has disabled public write access.
Hi Janice

Can you update the ticket that you are still having problems

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul Yes I've done that. This guy seems to have hit the same thing and it's on a local MAMP installation so would not have been an offline issue.
www.joomlabamboo.com/index.php?option=com_kunena&view=topic&catid=686&id=115357&Itemid=215#150461

Also can you tell me the default settings for the Featured module in the aside position. I've tried all I can think of but still can't get the h3 bg color to show.

Thanks
Jan
  • Janice Jones's Avatar
  • Janice Jones
  • LIfetime Developer - Big Bamboo
  • 124 posts
  • 5 Thanks
  • Karma: 0
The administrator has disabled public write access.
Hi Jan,

I think that member changed a setting in the template admin settings so changing the theme would have had no effect

e.g. changing a row style

So I think its a different issue

Are you able to planning to move to working online any time soon? that would be the quickest way of making progress

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I did exactly as he did. Changed a font from the default google using the original flat theme saved and compiled and the layout changed. Once I've changed it for that theme it seems to stick. Change the theme and the issue came back. I still think it's as simple as the default setting for the theme being incorrect. At the end of the day I can correct that but I can't find any way at all to get the h3 background back in the features module. I updated the template because the version in the quick start was 1.0 and it was updated to 1.01 because of an issue with the aside module. That then broke the heading background.
I have a large on line site I want to use this on but I need to have some confidence in it first as it has a high SEO rating and I don't want that to be offline for long while I make changes.
  • Janice Jones's Avatar
  • Janice Jones
  • LIfetime Developer - Big Bamboo
  • 124 posts
  • 5 Thanks
  • Karma: 0
The administrator has disabled public write access.
Hi Janice,

Can you include this in a reply to a ticket - its best to work in one place as we (the JB team) are in different time zones and its more efficient to have one point of reference

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I did Paul :)
I've given up on it and deleted the module. I've decided I can live without it and use something else. Thanks for your help.
Jan
  • Janice Jones's Avatar
  • Janice Jones
  • LIfetime Developer - Big Bamboo
  • 124 posts
  • 5 Thanks
  • Karma: 0
The administrator has disabled public write access.
Thanks Jan,

Can I just check are you referring to the template or just the zentools module?

e.g. you still have a problem with the template but the module part of the question is no relevant?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Janice,

Just confirming this here - it's an issue with the theme that gets shipped by default. If you change the row style for banner to inherit it will prevent this from happening. So you were spot on there.

I've just added a fix locally that fixes that issue with the sidebar bg colour not showing up.

Thanks for spotting that. I will include this in a fix for this week.

Thanks
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
You are a superstar! So I'm not going completely mad...
It's been about 5 years since I've done any web design per se and the world has changed considerably.
Thanks Anthony. Love the product and the concept and the design is stunning!
Off for a quick walk to the beach and I can get on with this.
thanks again.
Jan
  • Janice Jones's Avatar
  • Janice Jones
  • LIfetime Developer - Big Bamboo
  • 124 posts
  • 5 Thanks
  • Karma: 0
The administrator has disabled public write access.
Thanks Janice,

Hope you enjoyed the walk :)

Good luck with the site

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
The following user(s) said Thank You: Janice Jones

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers