Must Read: New Unified System is officially live Must Read     |   6 Templates Updated (27 April 2018) Read more

Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Zentools Lightbox not displaying as per settings

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi Guys,

I am using Zentools2 on a non JB template, and whereby it mostly works there seems to be some issues with the lightbox function.

Firstly, I have selected to show the fulltext in the lighbox and to strip images, however on clicking only the image shows up - I have created a custom css and recompiled it to no affect.

Basically what I want is to just display the article content in a lightbox.

Additionally, on checking an older site whereby this was working, the lightbox no longer shows up at all? Has there been a recent update which may have affected this functionality?

Regards
D
  • gntodd's Avatar
  • gntodd
  • LIfetime Developer - Big Bamboo
  • 44 posts
  • Karma: 0
The administrator has disabled public write access.
Hi D

Sounds like either a module setting or a js conflict

Have you checked the console in the admin and the front end of the site?

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

Neither site has any related console errors. www.perthcathedral.co.uk/ Does not have any console errors at all on the home page where the error is occurring.

The other site does have a single console error but it is related to an Instagram feed.

Its very odd to say the least.
Regards
D
  • gntodd's Avatar
  • gntodd
  • LIfetime Developer - Big Bamboo
  • 44 posts
  • Karma: 0
The administrator has disabled public write access.
With JCH I'd always suggest testing with it turned off

Have you tried this?
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
In regard to update - not that I'm aware of

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul, It is the same behaviour with JCH disabled - the lightbox does not appear when clicking the item on www.perthcathedral.co.uk/

Additionally, JCH is not enabled on the other site either.

Regards
D
  • gntodd's Avatar
  • gntodd
  • LIfetime Developer - Big Bamboo
  • 44 posts
  • Karma: 0
The administrator has disabled public write access.
Hi D,

Are you referring to the module id 1167?
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Or the module with Photo Gallery as title

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul, Its the announcements section - zentools-1168

When clicking the image, the content use to pop up in a light box. Nothing seems to happen now. I've checked the settings for the module but for the life of me cannot see anything wrong...might be a wood/trees issue.

Regards
D
  • gntodd's Avatar
  • gntodd
  • LIfetime Developer - Big Bamboo
  • 44 posts
  • Karma: 0
The administrator has disabled public write access.
Hi D,

So at the moment, the content behaviour is set to none?

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul, I've just been in and checked and all of the options are set as lightbox - please see attached screenshot.

Regards
D
  • gntodd's Avatar
  • gntodd
  • LIfetime Developer - Big Bamboo
  • 44 posts
  • Karma: 0
The administrator has disabled public write access.
Hi D,

There isn't a screenshot attached

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Apologies Paul, it might have been too big. I'll try again.

File Attachment:

File Name: screenshot.zip
File Size: 442 KB
  • gntodd's Avatar
  • gntodd
  • LIfetime Developer - Big Bamboo
  • 44 posts
  • Karma: 0
Last Edit: 3 months 2 weeks ago by gntodd. Reason: File not attached
The administrator has disabled public write access.
Ok I'll have a look in the ticket

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul, any update on why the lightbox isn't firing?

Regards
D
  • gntodd's Avatar
  • gntodd
  • LIfetime Developer - Big Bamboo
  • 44 posts
  • Karma: 0
The administrator has disabled public write access.
Sorry I'm paddling furiously at the moment

I will look at this tonight when I'm back home

sorry for the delay on this

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Not entirely sure this wasn't working

I rebuild the module with the single article and it is working now

Can you try

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi D,

Not sure if you saw my update as the server was having problems at the time and my reply got initially repeated 3 times

I rebuilt your module I can only assume there was a caching issue with it

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers