Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Icon Not Aligned To Centre & Small Gap When Hovering over Grid Images

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi,

Using latest firefox, win 10, 1920x1080.

1) I believe the icon's meant to be aligned to the centre below:

0z-jb-zentools2iconnotalignedtocentreasmentionedbefore.png


2) When you hover over the grid images, I see a small gap or gaps (it might be extra margin or padding - I didn't investigate) on the sides of the hovered image, that I don't think should be there:

0z-jb-whitespacebelow.png


0z-jb-whitespacerightandbelow2.png


0z-jb-whitespacerightandbelow.png


0z-jb-whitespaceright.png


Aadil
  • Aadil's Avatar
  • Aadil
  • LIfetime Developer - Big Bamboo
  • 292 posts
  • 13 Thanks
  • Karma: 4
The administrator has disabled public write access.
hmm Thought I'd replied to this but obviously didn't click to send

I think there is an issue with how firefox is dealing with the pixel fractions in the hover meaning it is exposing the background.

It's creating the fraction as it divides the images up to fill the space - Chrome has a slightly different rounding compared to Firefox

This is my working theory at the moment
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

Aah okay, I see. Is there an update that could be implemented (when you guys get done with your current template work)?
I opened up grid4 in Edge and the background slideshow at the very top, is jittery when you scroll down - not sure if you noticed but thought I should mention it while on topic.

Also, I think I asked about this before but are you guys going to look at a way to centre the icon that shows up on hover (from the other layout that has images, above)?
  • Aadil's Avatar
  • Aadil
  • LIfetime Developer - Big Bamboo
  • 292 posts
  • 13 Thanks
  • Karma: 4
Last Edit: 3 years 10 months ago by Aadil.
The administrator has disabled public write access.
hmm I'd missed that in Edge

I'll need to ask on that
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Regarding the icons

I tested this with using the latest zentools2 and it does fix the issue on the demo

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
You would need to compile the master less file

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Thanks for the update. I usually look at and experiment in the browser when I'm on your demo pages because I assume they're the most up to date.

Regards,
Aadil
  • Aadil's Avatar
  • Aadil
  • LIfetime Developer - Big Bamboo
  • 292 posts
  • 13 Thanks
  • Karma: 4
The administrator has disabled public write access.
Yes it should be updated

I'll see if I can get this addressed

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi,

zentools2.joomlabamboo.com/zentools2-examples - I had a loot at this page with the examples (latest firefox) and I still see white spaces below some of the images in the "Fullscreen Masonry" example - I wanted to know if your recent update fixed this issue?

I won't have the time to go through installing & testing for bugs so from now on, I'll likely only be evaluating your demo site installs (unless I end up installing & needing to use the extension).

Regards,
Aadil
  • Aadil's Avatar
  • Aadil
  • LIfetime Developer - Big Bamboo
  • 292 posts
  • 13 Thanks
  • Karma: 4
The administrator has disabled public write access.
Hi Aadil,

Sorry we haven't been very responsive to your posts
Unfortunately with the change of ownership we need to get template releases out

The issues are on the tracker but we've not got to some of them

The demo site really needs to be updated - I would check the latest template installs for issues with zentools2 as these contain the latest zentools2 version

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
The following user(s) said Thank You: Aadil

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers