Must Read: New Unified System is officially live Must Read     |   11 Templates & 4 Extensions Updated Read more

Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Responsive Template Front Page images doesn't show up with PHP 7.0.10

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

I have been using the Responsive Template, which I purchased back in 2013. I am using it at home on my Local Server as I am still building the website.

I have no problems using this old (2013) Template with php 5.6.25, but when I change the version to php 7.0.10, the images on the Homepage do not show up.

Thinking that this might be because it is an old template, since Responsive2 was released in 2015, I just paid a year's subscription and downloaded Responsive2.

The same issue is happening Responsive2: the images on the Front Page do not show up with php 7.0.10.

I'm not a tech person, I learn what I need to learn to do what I need to do.

There are two reasons that I tried to use php 7.0.10 - the first is that when I loaded my site to test on a web host, the images disappeared, and the support person finally figured it out, and changed the php version to 5.6.25. But the fact that the web host (Siteground) uses php7 by default makes me think it might be necessary? Secondly, I read somewhere that php 5 will not be supported for too much longer?

Bottom line.... can someone tell me why the images disappear when using php 7?


Attached two image: Homepage screenshot using php 5.6.25, and Homepage screenshot using php 7.0.10.
Attachments:
  • mariazzz's Avatar
  • mariazzz
  • 12 Month basic
  • 6 posts
  • Karma: 0
The administrator has disabled public write access.
Hi There,

Are these images displayed using the zentools module?

Have you upgraded to the latest zentools module?

Thanks
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
If you using zentools the latest version is

JB_mod_zentools_J3+_1.14.1.zip
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul

Sorry, but I didn't realise you replied until today (i.e. months later).

Thanks for your help, and yes it did (eventually) solve the problem.

However ... I hope Zentools doesn't update regularly because it's a lot of trouble. It wasn't just a case of loading an update. I have to recreate my eight home page tabs AND the it's taken me ages to redo the CSS.

What I don't understand is why the updates to Zentool and Responsive2 had to change all the HTML - all my CSS has to be redone, and it's so frustrating. (Not your issue I know, but I am so frustrated I have to have a whinge somewhere).
Thanks
Maria
  • mariazzz's Avatar
  • mariazzz
  • 12 Month basic
  • 6 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Maria,

Zentools 1.14.1 should be just a case of installing over the top of the existing modules

Can you tell me bits you changed?

I'm sorry this has meant more work for you

Kind regards,
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul

I only just saw this response today when I came to write another question.... I don't understand why I don't seem to see (or get?) these responses by email.

I wrote my own css in the custom.css file, and the html that I used to style is
different to the html that is in Responsive 2....
  • mariazzz's Avatar
  • mariazzz
  • 12 Month basic
  • 6 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Maria,

Sorry if you missed the email - it might have gone into the spam box

Do you have the latest zentools installed?

Thanks
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
If possible can you confirm you got the email

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

Confirming I got your email, thanks.
  • mariazzz's Avatar
  • mariazzz
  • 12 Month basic
  • 6 posts
  • Karma: 0
The administrator has disabled public write access.
What version number of zentools are you using?

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers