Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Cannot get home menu item to show

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

:unsure: For the life of me, I cannot get the Home menu item to show in the main menu of the site. The content shows as it should, but I just cannot get the Home link to appear in the menu. I have gone through and checked that I have unique aliases set for each menu item. I've thrown out all the trashed menu items on the site. Any help is much appreciated!
  • Eric Darling's Avatar
  • Eric Darling
  • 3 Month Basic
  • 12 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Hi

Do you have a link for the site?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
www.grimygulch.com
  • Eric Darling's Avatar
  • Eric Darling
  • 3 Month Basic
  • 12 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
There is no text in the home menu item, so it looks like the option to display the title is turned off in the menu item edit screen.

The active class also always seems to be on the homepage item. Are you using an seo plugin such as sh404sef that changes the way urls work?
  • Robert Went's Avatar
  • Robert Went
  • Moderator
  • 2210 posts
  • 196 Thanks
  • Karma: 90
Last Edit: 2 years 8 months ago by Robert Went.
The administrator has disabled public write access.
No URL modifying plugins installed. I've toyed with settings of all sorts in the menu item. Showing title does nothing, but that's not what I want regardless. I want the menu item to show, not its title on the page content.
  • Eric Darling's Avatar
  • Eric Darling
  • 3 Month Basic
  • 12 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Odd - I'm assuming if you switch to a default Joomla template you get the same?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
No. If I switch to Protostar, and publish the Menu's module to the Navigation position, Home shows up like it should. Check it out when you get a chance - I've left Protostar as the default.
  • Eric Darling's Avatar
  • Eric Darling
  • 3 Month Basic
  • 12 posts
  • 1 Thanks
  • Karma: 0
Last Edit: 2 years 8 months ago by Eric Darling.
The administrator has disabled public write access.
Can you open a ticket and we will take a look

Thanks
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
OK, new ticket created. Thank you for following up!
  • Eric Darling's Avatar
  • Eric Darling
  • 3 Month Basic
  • 12 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Thanks
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
And just answered

Cheers
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Thank you - just for anyone else who happens on this thread in the future with a similar issue - the setting in the menu item's Zen Menu tab for Show Item Title needed to be set to "Yes."
  • Eric Darling's Avatar
  • Eric Darling
  • 3 Month Basic
  • 12 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
The following user(s) said Thank You: manh
Thanks Eric
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers