Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Main content collapses over 1080px

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi,

Using Venture with no sidebar modules, the main content area collapses over 1080px. But this is not so with the demo. I need to fix this. :)

I used quickstart Venture v 1.3.2 but when I check the zengrid.xml it says I have zgfw4 v. 1.3.2.

Is this the problem?

Thanks,
Helen
  • Helen Nunley's Avatar
  • Helen Nunley
  • LIfetime Developer - Big Bamboo
  • 1024 posts
  • 3 Thanks
  • Karma: 7
The administrator has disabled public write access.
Hi Helen,

What are the breakpoint values for the template?

The quickstart grid collapse is 1080px - have you tried changing that?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

The collapse works fine under 1080px. My problem is it is collapsing over 1080px.

Working locally. Use this page for example. demo.joomlabamboo.com/index.php?theme=feb15

When over 1080px the main content area gets smaller like it is saving room for a sidebar module.

See attached.


2015-08-17_1141.png




2015-08-17_1142.png
  • Helen Nunley's Avatar
  • Helen Nunley
  • LIfetime Developer - Big Bamboo
  • 1024 posts
  • 3 Thanks
  • Karma: 7
The administrator has disabled public write access.
Will you have a link any time soon?

Does this site have zenkit enabled or any bootstrap enabled?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
No Bootstrap, Zenkit is enabled but this is a link with Joomla category blog, not K2.

I won't have a link for a while yet. If I can, I will upload to a test environment. :)
  • Helen Nunley's Avatar
  • Helen Nunley
  • LIfetime Developer - Big Bamboo
  • 1024 posts
  • 3 Thanks
  • Karma: 7
The administrator has disabled public write access.
Hmm problem is I can't reproduce it locally

If you cost a link that would be handy

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

Here's that link:

prettygoodhost.com/shrinemont/joomla/category-blog/category-blog-3
  • Helen Nunley's Avatar
  • Helen Nunley
  • LIfetime Developer - Big Bamboo
  • 1024 posts
  • 3 Thanks
  • Karma: 7
The administrator has disabled public write access.
Hi Helen,

What layout are you using?

What width is the main area set as in the template settings?

Is it possible to attach a screenshot of your layout settings for this area

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Main area is 4, 4, 4 with force even widths enabled.

What all (I'm from the South) do you need a screen shot of and I'll grab it?
  • Helen Nunley's Avatar
  • Helen Nunley
  • LIfetime Developer - Big Bamboo
  • 1024 posts
  • 3 Thanks
  • Karma: 7
Last Edit: 6 years 2 weeks ago by Helen Nunley.
The administrator has disabled public write access.
Hi Helen,

Bit odd this one

Can you upgrade to the latest release and see if that works

Please save in the template settings after update to ensure its been recompiled

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Upgraded to newest template and recompiled settings. Still no change.

I just checked on another site and it does work correctly there so I must have a conflict somewhere... I will keep working on this.

If you see anything, please let me know. :)
  • Helen Nunley's Avatar
  • Helen Nunley
  • LIfetime Developer - Big Bamboo
  • 1024 posts
  • 3 Thanks
  • Karma: 7
The administrator has disabled public write access.
I'm close. It has to do with my Ohanah modules "saving" space on non-Ohanah pages. I need to tweak them a little...
  • Helen Nunley's Avatar
  • Helen Nunley
  • LIfetime Developer - Big Bamboo
  • 1024 posts
  • 3 Thanks
  • Karma: 7
The administrator has disabled public write access.
interesting :)
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
OK, seems Ohanah doesn't play well with ZGFW4. Even though Ohanah has made great improvements since J3, there are certain views that still remain problematic. So assigning module position works fine but you must also assign to the Ohanah component using NoNumber Advanced Modules. And even then some Ohanah views still act as if there is an empty module published there. Ohanah's module has options to not show them in these views, but that is what doesn't work with ZGFW4.

After receiving help from Ohanah, Igor could only fix this by custom css of:
.com_ohanah.view-events .zg-col-8 {
  width: 100%;
}

.com_ohanah.view-registration .zg-col-8 {
  width: 100%;
}

Not perfect, but it works.

Hopefully this might help someone else.
Helen
  • Helen Nunley's Avatar
  • Helen Nunley
  • LIfetime Developer - Big Bamboo
  • 1024 posts
  • 3 Thanks
  • Karma: 7
Last Edit: 6 years 1 week ago by Helen Nunley.
The administrator has disabled public write access.
The following user(s) said Thank You: manh
Thanks Helen

I'm sure it will

Thanks again for taking the time to post back

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers