Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Error "undefined offset: 0" in zenmenu

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

HI,
I've installed the Zenmenu plugin with the new Venture template and I'm getting the following error:
Notice: Undefined offset: 0 in C:\xampp\htdocs\wlscmmigrate\templates\venture\html\mod_menu\default_component.php on line 19

I'm no expert, but I can look at this line and see:
// Module
$display_module = $item->params->get('zenmenu_display_module');
$display_module = $display_module[0];

I have no idea what to do about it.

The error shows up on my site's front end, and the menu is oddly formatted as it seems to cause a line break within the menu (this error appears above the menu item, centered, and even above subitems in a menu so the top level menu items don't continue across the screen, they break.)

Thanks for any advice!
Janette
  • Janette Tilley's Avatar
  • Janette Tilley
  • 12 Month basic
  • 13 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Janette,

Is this the latest template version?

www.ostraining.com/blog/joomla/warnings/

Notices aren't always errors and can be due to error reporting being set to high in the local host

You can turn the error reporting in the global config to simple or none to get rid of the notice

The notice is unlikely to appear on a live host

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Janette,

I actually discovered this yesterday and will release a fix later today.

If you need it before then please post a ticket with ftp details and Ill fix this for you.
Thanks
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
If I set error reporting to "none", the messages do disappear. If I set it to "system default", though, the message appears above or below every menu item.
Not sure if this is something I should be worried about. I'm no expert, but I usually set error reporting to "system default".

Thanks!
Janette
  • Janette Tilley's Avatar
  • Janette Tilley
  • 12 Month basic
  • 13 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Janette,

we are working on an update for this issue

Error reporting comes in handy when in development e.g. if things break or show errors or issues

Its best to turn error reporting to none when a site is released/live so as to give no guidance/pointer to potential hackers

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi
I have the same issue. Is the update already released?

I know I can change the reporting settings but at this stage of the development I would like to keep it default so this notice messages destroy the design...

I am developing locally so I am not sure I can provide the ftp access. Is there a way to fix this myself.
  • Evgeny Filimonov's Avatar
  • Evgeny Filimonov
  • 3 Month Basic
  • 34 posts
  • Karma: 0
The administrator has disabled public write access.
Hi

Do you have the latest version of the template installed?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Yes. The last one from your site
  • Evgeny Filimonov's Avatar
  • Evgeny Filimonov
  • 3 Month Basic
  • 34 posts
  • Karma: 0
The administrator has disabled public write access.
Thanks for the update

I'll check with the developers when they are online tonight

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Thank you Paul,

but around 1 month ago Anthony said he had a fix for this issue. Could I get it?

Regards,
Evgeny
  • Evgeny Filimonov's Avatar
  • Evgeny Filimonov
  • 3 Month Basic
  • 34 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Evgeny,

With you having the same/similiar issue I need to check with the developers regarding what was changed

I will check with Anthony later today when he is online

I'm sorry for the delay on this

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

do you have any news for me?
  • Evgeny Filimonov's Avatar
  • Evgeny Filimonov
  • 3 Month Basic
  • 34 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Evgeny

Do you get the same notice with the latest released version?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
wow I see you upload an update. I did not try yet.
Thanks. I try and return to you
  • Evgeny Filimonov's Avatar
  • Evgeny Filimonov
  • 3 Month Basic
  • 34 posts
  • Karma: 0
The administrator has disabled public write access.
I'm not 1 100% sure if it fixes it as the notice doesn't show on my local install
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I was getting this error, too. (but only in Firefox, never in Safari)

Notice: Undefined offset: 0 in ...


However, I installed the latest version of my template (Rasa2) and the latest version of ZenMenu.
It's working fine now, and the error has disappeared.

Thanks!!
Kara
  • karjoco's Avatar
  • karjoco
  • 3 Month Basic
  • 5 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Kara,

Thanks for the update

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Paul,

I have the following results:
1. I met the "undefined offset: 0" issue on the local version of my site (windows version of XAMPP)
2. After returning it back to my hosting the issue was resolved itself (with the old template version)
3. But anyway I have upgraded the template

So I can not say does the new template version help with this issue on the local version or not because i don't have the access to the local installation now.
  • Evgeny Filimonov's Avatar
  • Evgeny Filimonov
  • 3 Month Basic
  • 34 posts
  • Karma: 0
Last Edit: 6 years 3 weeks ago by Evgeny Filimonov.
The administrator has disabled public write access.
Thanks for the update - good luck with the site :)

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers