Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

itemid=101 redirects, image size problems

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi guys,

I'm trying to build a site for my music using Focus2. In the process I've set up a zentools module on the homepage to link to some of my previous work.

robertlcamp.com

For some reason, all of the links but one ("These Mortals") redirect to the homepage. In looking at the urls I see that those redirects all have an itemid=101 appended. I've looked for info on this and found that there are workarounds but it seems to me there must be something simple I've done, or not done, that would fix this problem. I've checked the redirected articles against the working one for differences but I can't find any. I've also been all through the zentools module but if there's something in there that would help I haven't found it.

Another, much less important, problem is that regardless of what I do (change image size, change image itself, change cropping option, etc.) one of the images ("Paper Sons, Paper Daughters") is always rendered larger or smaller than the rest. There's probably an obvious reason for why this happens, but it's beyond me.

Hoping you guys have some ideas.

Thanks

Bob Camp
  • RobertCamp's Avatar
  • RobertCamp
  • 3 Month Basic
  • 155 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Bob,

With the pages redirecting to the home page - are these pages in a menu on the site?

for pages to load correctly they need a menu link either as an individual article or as a blog link

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
For more information on this check out this link

www.joomlabamboo.com/blog/how-to-joomla/how-to-avoid-the-joomla-menu-itemid-issue

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Looking at the image - it looks ok for me - is this on a specific browser?

or is the problem fixed?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

Sorry about the delay. I stupidly posted my questions the evening before going on a long weekend.

I just checked and it looks like your suggestion about menus is right. I'll check out the link you posted. I knew it would be something fairly simple, but I obviously still don't understand the basics of the platform well enough to figure it out on my own.

The image, the black and white one under Paper Sons, Paper Daughters, is actually bigger if you zoom in a bit. Like I said, it's not a huge deal, but I'm not sure the configuration I've currently got going in the module is what I'll end up with, and in other configurations the image size is more noticeable. I'll keep testing to see if I can figure out why it sizes that one image differently from the others.

Anyway, thanks, as usual, for your help, and apologies again for the delay.

Bob
  • RobertCamp's Avatar
  • RobertCamp
  • 3 Month Basic
  • 155 posts
  • Karma: 0
The administrator has disabled public write access.
No worries Bob about the delay in replying to me :)

The issue with links reloading the home page trips everybody up and is the most frequent asked question I think in the entire forum
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
Last Edit: 3 years 10 months ago by manh.
The administrator has disabled public write access.
Hi Bob,

With the images are the originals all the same size?
e.g the images uploaded prior to being resized

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I tried several different images to determine if that was the problem. I even used the same images that are working fine for the other links. It didn't change anything. I also changed the order of the links to see if that made a difference. The first was was always sized a tiny bit bigger than the rest.

I know there are likely many other factors I haven't accounted for yet but it seems like there's something in the module that's affecting this.

I'll double check everything just to be sure.

Bob
  • RobertCamp's Avatar
  • RobertCamp
  • 3 Month Basic
  • 155 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Bob,

Can you confirm the browser you see this in

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers