Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Warning with images loading in grid

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

On adding some images into a grid, I get the following when I view the page:
Warning: imagecolorsforindex(): Color index 245 out of range in …/modules/mod_zentools/includes/imageresize.php on line 368
If I reload the page, the warning disappears.

Any ideas what is causing this?
(Site is on joomla 3.6)
  • Larry Pitts's Avatar
  • Larry Pitts
  • 12 Month basic
  • 39 posts
  • Karma: 0
The administrator has disabled public write access.
Are you using the latest zentools v1 version?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Also what php version are you using on the site?

Cheers
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Yes - latest Zentools v 1.14.1
php is 5.6.2
  • Larry Pitts's Avatar
  • Larry Pitts
  • 12 Month basic
  • 39 posts
  • Karma: 0
The administrator has disabled public write access.
Is this a live or a localhost?

What level is error reporting set at?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Working on the site locally, and error reporting set to Development
  • Larry Pitts's Avatar
  • Larry Pitts
  • 12 Month basic
  • 39 posts
  • Karma: 0
The administrator has disabled public write access.
hmm this isn't an error I've seen before in context with this module

What local host are you using?

Is the localhost configuration itself still using the default error reporting level?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
On MAMP, Developer error reporting.
After a lot of searching on the web, I found it was being caused by an animated gif. I had to resave the gif from photoshop (no change to settings!) and then the error disappeared.
  • Larry Pitts's Avatar
  • Larry Pitts
  • 12 Month basic
  • 39 posts
  • Karma: 0
Last Edit: 2 years 9 months ago by Larry Pitts.
The administrator has disabled public write access.
ah ok I was referring to the php file itself e.g. php.ini on xampp

Thanks for the update on the gif

I've not heard of people using one in the module

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Actually, the gif was not in the module - it was in the article on the page where the zentools module was loading. On other pages, same module but no gif, the warnings did not occur.
  • Larry Pitts's Avatar
  • Larry Pitts
  • 12 Month basic
  • 39 posts
  • Karma: 0
The administrator has disabled public write access.
Hi

Can you attach the gif in a zip file in this thread

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
NP - in zip is both the original (which caused the problem) and the rv one which worked.
Cheers

File Attachment:

File Name: GIFs.zip
File Size: 43 KB
  • Larry Pitts's Avatar
  • Larry Pitts
  • 12 Month basic
  • 39 posts
  • Karma: 0
The administrator has disabled public write access.
Is the problem resolved now on your site?

If I add the gifs to a test site it doesn't crash but the gifs don't animate at all

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Don't know why they are not animating for you - when opened directly into a browser, they both animate, however only the revised one works on my site. As I said, I had to open and then re-save it from within Photoshop before it would work in the template (no idea why!).
  • Larry Pitts's Avatar
  • Larry Pitts
  • 12 Month basic
  • 39 posts
  • Karma: 0
The administrator has disabled public write access.
I think I'm doing something wrong in photoshop somewhere

If it is ok on your site then I think we are ok?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Yes, all OK this end.
FYI, attached are the settings used to re_export from Photoshop, using 'Save for web'
Cheers,
LARRY

ScreenShot2016-11-08at11.47.59AM.png
  • Larry Pitts's Avatar
  • Larry Pitts
  • 12 Month basic
  • 39 posts
  • Karma: 0
The administrator has disabled public write access.
Thanks Larry,

I'll give this a go in the morning again

Best of luck with the site

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers