Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Error Frontpage right after installation QuickStart

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi i've installed several templates from Joomla Bamboo, but the NewStream2 has an issue.
Right after i did the installation i try to access the frontpage it gives me this error:

MEMBER LOGIN
Parse error: syntax error, unexpected 'defined' (T_STRING) in /home1/epfound/public_html/[WEBSITE URL]/templates/newstream2/tpls/blocks/nav-content.php on line 1

What's happening here?
  • Elfpath's Avatar
  • Elfpath
  • 12 Month basic
  • 6 posts
  • Karma: 0
The administrator has disabled public write access.
Hi

What php version are you running?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
PHP Version 5.4.35

PHP Information

PHP Version 5.4.35



System Linux gator4039.hostgator.com 3.12.35.1418868451 #1 SMP Wed Dec 17 20:10:32 CST 2014 x86_64
Build Date Nov 24 2014 02:55:30
Configure Command './configure' '--with-libdir=lib64' '--enable-bcmath' '--enable-calendar' '--enable-dbase' '--enable-exif' '--enable-' '--enable-ftp' '--enable-gd-native-ttf' '--enable-libxml' '--enable-mbstring' '--enable-pdo' '--enable-soap' '--enable-sockets' '--enable-sqlite-utf8' '--enable-wddx' '--enable-zip' '--prefix=/opt/php54' '--with-bz2' '--with-curl' '--with-freetype-dir' '--with-gd' '--with-gettext' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl' '--with-mcrypt=/opt/libmcrypt' '--with-kerberos' '--with-jpeg-dir=/usr' '--with-xsl' '--with-mhash' '--with-mssql' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/usr/bin/mysql_config' '--with-openssl' '--with-pdo-mysql=/usr' '--with-png-dir' '--with-pspell' '--with-tidy' '--with-unixODBC' '--with-xmlrpc' '--with-zlib' '--enable-intl' '--with-gmp' '--with-sqlite'
Server API CGI/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /opt/php54/lib
Loaded Configuration File /opt/phpcur/lib/php.ini
Scan this dir for additional .ini files (none)
Additional .ini files parsed (none)
PHP API 20100412
PHP Extension 20100525
Zend Extension 220100525
Zend Extension Build API220100525, NTS
PHP Extension Build API20100525, NTS
Debug Build no
Thread Safety disabled
Zend Signal Handling disabled
Zend Memory Manager enabled
Zend Multibyte Support provided by mbstring
IPv6 Support enabled
DTrace Support disabled
Registered PHP Streams https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar, zip
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
Registered Stream Filters zlib.*, bzip2.*, convert.iconv.*, mcrypt.*, mdecrypt.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk


This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
with the ionCube PHP Loader v4.4.3, Copyright (c) 2002-2013, by ionCube Ltd., and
with Zend Guard Loader v3.3, Copyright (c) 1998-2013, by Zend Technologies
  • Elfpath's Avatar
  • Elfpath
  • 12 Month basic
  • 6 posts
  • Karma: 0
Last Edit: 5 years 7 months ago by Elfpath.
The administrator has disabled public write access.
Thanks for the info

You've installed other joomla bamboo quickstarts to the same server?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Yes same server. Different domains. Admin panel is fully functional... Which seems a bit strange...
  • Elfpath's Avatar
  • Elfpath
  • 12 Month basic
  • 6 posts
  • Karma: 0
Last Edit: 5 years 7 months ago by Elfpath.
The administrator has disabled public write access.
If you re-install the T3 plugin does that help?

Just to clarify you have installed Joomla Bamboo templates to this server already on a different domain?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
No. reinstalling the T3 Plugin doesn't help.

Yes and that all worked fine. Its just this template...
  • Elfpath's Avatar
  • Elfpath
  • 12 Month basic
  • 6 posts
  • Karma: 0
Last Edit: 5 years 7 months ago by Elfpath.
The administrator has disabled public write access.
Will need to get back to you on this one

sorry for the delay

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Talking to our team (thanks Rob)

Can you try re-installing the template using the standard template and see if that works better

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
What do you mean by using the standard template?
  • Elfpath's Avatar
  • Elfpath
  • 12 Month basic
  • 6 posts
  • Karma: 0
The administrator has disabled public write access.
From the template download page there are two versions of the template to download

The quickstart file and the other much smaller file which is the template only

Can you install it via the standard joomla installer - please don't delete anything

Thanks
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

Last step did the job. Thanks for your help!

Regards,
Elfpath
  • Elfpath's Avatar
  • Elfpath
  • 12 Month basic
  • 6 posts
  • Karma: 0
The administrator has disabled public write access.
No problem

Good luck with the site

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers