Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

SEF break image load

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi, I've enabled SEF and Falang for my site.
I've a slideshow zentools in homepage that doesn't work if SEF is enabled because images are searched on wrong folder.
Example: for my English version, module search image under www.mysite.com/en/media .... instead of www.mysite.com/media/ ... (note the language code in the url).

You can check it here: www.montinibags.it/.
Try to switch to english versione and see what happen to main slideshow in homepage.
Italian version works because I've set language filter to remove language code for default site language.

Can I force module to load relative urls?
How can I fix that please?
Thank you.
  • enrico fiorani's Avatar
  • enrico fiorani
  • 12 Month Developer
  • 29 posts
  • Karma: 0
Last Edit: 5 years 9 months ago by enrico fiorani.
The administrator has disabled public write access.
What version number of zentools are you using?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi, I'm using version 1.11.5.
Thank you.
  • enrico fiorani's Avatar
  • enrico fiorani
  • 12 Month Developer
  • 29 posts
  • Karma: 0
The administrator has disabled public write access.
Paul, I've upgraded zentools module right now but problem still remain.
Thank you.
  • enrico fiorani's Avatar
  • enrico fiorani
  • 12 Month Developer
  • 29 posts
  • Karma: 0
The administrator has disabled public write access.
Does it work if you turn off responsive options in the module?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi, sorry for my late response.
How responsive option can solve the problem? Anyway, I don't know how to turn off responsive option for component?
Thank you.
  • enrico fiorani's Avatar
  • enrico fiorani
  • 12 Month Developer
  • 29 posts
  • Karma: 0
The administrator has disabled public write access.
It has been a previous bug where the path was affected by the responsive image section in zentools

this is the setting I'm referring to

zentools.joomlabamboo.com/specifying-image-sizes-based-on-screen-sizes

Is the resize image on screensize off?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Yes I've both enabled.
Slideshow works if I'm on www.montinibags.it but don't work if I visit the english version on www.montinibags.it/en/.

Note that if I remove the last slash on english version url (www.montinibags.it/en) slideshow works as exptected.
Please try it yourself.
Thank you.
  • enrico fiorani's Avatar
  • enrico fiorani
  • 12 Month Developer
  • 29 posts
  • Karma: 0
The administrator has disabled public write access.
Have you tried disabling the image option I suggested?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Yes, with no success.
I notice that my original versione (Italian) has a simple img tag for slide, like that:
<img title="Slide3" alt="Slide3" src="/images/prodotti/slide2.jpg" data-original="images/prodotti/slide2.jpg" original="/images/prodotti/slide2.jpg">

English version, that not works, has:
<img title="Slide3" alt="Slide3" data-src1281="media/mod_zentools/cache/images/slide2-46ca2673ce92df598717468f227aa359.jpg" data-src1025="media/mod_zentools/cache/images/slide2-46ca2673ce92df598717468f227aa359.jpg" data-src769="http://www.montinibags.it//media/mod_zentools/cache/images/slide2-46ca2673ce92df598717468f227aa359-53d40d7cf68b8facd1d548cc15893c09.jpg" data-src481="http://www.montinibags.it//media/mod_zentools/cache/images/slide2-46ca2673ce92df598717468f227aa359-0d909706326187f8f9aa5e4cc4370222.jpg" data-src320="http://www.montinibags.it//media/mod_zentools/cache/images/slide2-46ca2673ce92df598717468f227aa359-0d909706326187f8f9aa5e4cc4370222.jpg" src="media/mod_zentools/cache/images/slide2-46ca2673ce92df598717468f227aa359.jpg" data-original="http://www.montinibags.it//media/mod_zentools/cache/images/slide2-46ca2673ce92df598717468f227aa359-0d909706326187f8f9aa5e4cc4370222.jpg" data-init-response="http://www.montinibags.it//media/mod_zentools/cache/images/slide2-46ca2673ce92df598717468f227aa359-0d909706326187f8f9aa5e4cc4370222.jpg" original="media/mod_zentools/cache/images/slide2-46ca2673ce92df598717468f227aa359.jpg">

Thank you.
  • enrico fiorani's Avatar
  • enrico fiorani
  • 12 Month Developer
  • 29 posts
  • Karma: 0
The administrator has disabled public write access.
Can you create a ticket so we can take a look

Thanks
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi there,

From the looks of it it seems like your english version of the module is using the old setting. Are you using two instances of the module? Can you try updating both?
Thanks
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
The following user(s) said Thank You: manh
Thank you Mr. Olsen!
Gotcha!
Some settings on falang component wasn't changed, now everything is ok!
Thank you again!
  • enrico fiorani's Avatar
  • enrico fiorani
  • 12 Month Developer
  • 29 posts
  • Karma: 0
The administrator has disabled public write access.
ah cool - thanks for the update

cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers