Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Nebula megamenu and Android issues

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

i am working on a new site and seem to be having issues in Nebula with the megamenu specifically on Android.

I tried off canvas navigation and that works great except that the site logo doesn't shift to the right and sits under the menu making it difficult to read.

I tried in-canvas navigation and that looks even better except that one of my menu items doesn't appear. specifically my Meet the team menu which has a second sub menu which displays modules in the menu. While i don't need to see the modules in the menu on a mobile device, i do need to see the main category link "Meet the Team" which will take them to a category view of the team members.

Site: Timmins Symphony Redesign

I am fine with correcting either issue but both are a problem. Either the logo needs to be shifted to the right or the missing menu item in the megamenu needs to display. (FYI i can click the blank area in the menu and it goes to the page so it may be changing the font to the same color as the background but i can't find anything in the CSS that indicates that it SHOULD be making any in-canvas menu items a charcoal grey.

Also on an unrelated topic, is there a way i can add a dark box behind the text in the zen tools banner slideshow text. All attempts i made so far also put the box behind the image as well which doesn't look very nice. I just want to make the text on the slideshow more readable.

thanks!
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 391 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
Hi

If possible can you separate out issues into separate threads :)

The second issue is the box-shadow

#bannerwrap .zen-container {-webkit-box-shadow: none; box-shadow: none;}

Depending on which one you want to remove this is the banner slideshow area - you want want to target the nav area as well

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Which is your preferred method of displaying the site? - is it as it is now?

What is the OS version and device?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Sorry about that. With the menu issue, i am testing on a Sony Ericsson Cell phone with Android 4.0.4

I have had the issue on other sites with the megamenu items not showing up so i think i would like to address that one first.

I did note that the logo does stay positioned properly when i tested by shrinking my browser window on my pc.
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 391 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
that wasn't quite what i had in mind for the banner text but it will do. i was hoping to only put the dark background behind the text and not the image. At least this looks more uniform so i can work with it. what i had tried before was putting a dark box behind each column and didn't go across the screen so this looks better. Sorry for posting the two issues in one place.

So now just the android matter.

thanks Paul
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 391 posts
  • 8 Thanks
  • Karma: 2
Last Edit: 8 years 5 months ago by candyce.
The administrator has disabled public write access.
Hi,

Looking at the site on a nexus 4 (kitkat) and sony expiria ray (jellybean) I can currently see all menu items including the 'meet the team' menu item on both phones.

This is using the built in chrome browser.

Regards,

Rob
  • Robert Went's Avatar
  • Robert Went
  • Moderator
  • 2210 posts
  • 196 Thanks
  • Karma: 90
The administrator has disabled public write access.
hi rob, that works for me too but if you are checking in google chrome the only thing that is really doing is showing you the different screen sizes. I use screenfly to test on various devices and tablets but i have also tested on several actual phones including an HTC 1 with Android 4.1.1 and the Sony Ericsson and we cannot see the Meet the TSO link. I also tried the off canvas navigation and it does the same thing with the logo overlapping the menu. the emulator tools all work fine and show the site well but it's not the reality of how it's actually working.
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 391 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
Hi,

I was checking on actual phones not emulating them and I can see all links and can use them all. Chrome is the stock browser for these versions of android.

Regards,

Rob
  • Robert Went's Avatar
  • Robert Went
  • Moderator
  • 2210 posts
  • 196 Thanks
  • Karma: 90
The administrator has disabled public write access.
my apologies, i thought you meant an emulator. chrome doesn't appear to be the standard browser on the phone we have here. Ok so in the off canvas the menus look fine except the logo isn't shifting over. Not sure if that might be the better approach then. you can still navigate from the menu but it looks bad. How can i set the logo to move to the right. i can try to take a picture of the phone display so you can see what i am talking about in both cases if that would help
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 391 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
Yes please do

Thanks
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Below are screenshots of my cell showing the two different issues i have identified and i am able to replicate on other devices.

I am not sure how to resolve either.
Attachments:
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 391 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
I'm not sure of the best way to try and debug this not being able to emulate it.

Does they same thing happen with another browser on the same phone or is it just with the built in one?

I attach a photo of what I see.

Rob
Attachments:
  • Robert Went's Avatar
  • Robert Went
  • Moderator
  • 2210 posts
  • 196 Thanks
  • Karma: 90
The administrator has disabled public write access.
yours looks great and i think the in-canvas menu is the way to go. it looks nicer. So i just need to figure out why that one menu item doesn't appear. it is definitely bizarre. the only thing that is different about that menu item is that on a larger screen it has a submenu item which contains a module.
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 391 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
Are you still having problems with this?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
yes unfortunately the issue remains unresolved.
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 391 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
Can you create a ticket so we can take a look

Please include a summary of this thread as Anthony may need to look at it

Also can you include ftp and joomla details

Thanks
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers