Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Nebula Quickstart + J2XML = broken template. Need advice.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Here's the link with the issue http://nccfc.net/nebulaquickstart

Hello folks. I installed the Nebula template and then used J2XML extension to bring over my categories and articles (because redMigrator just wasn't working).

My nebula template seems to bee missing some of the imagery form the template and my layouts menu shows doubles, the imagery next to brain food is missing, and the template loads rather slow.

Is there a way to get my template to work start like a clean install of the quickstart even though I've imported my categories and content?
  • Tangier Clarke's Avatar
  • Tangier Clarke
  • 12 Month basic
  • 136 posts
  • Karma: 0
Last Edit: 7 years 8 months ago by Tangier Clarke.
The administrator has disabled public write access.
Hi there,

Sorry for the delay.

That page wont load for me now.

Can you confirm the url?

Thanks Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
You are correct. I forgot one character in the URL.

It's http://nccfc.net/nebulaquickstart/
  • Tangier Clarke's Avatar
  • Tangier Clarke
  • 12 Month basic
  • 136 posts
  • Karma: 0
Last Edit: 7 years 8 months ago by Tangier Clarke.
The administrator has disabled public write access.
Hi,

I'm seeing a 500 error at that address.

At a guess, the j2xml component hasn't created the relevant entries in the assets table which would explain the speed problem.
You can try using the rebuild button in the menu and category screens to try and create the correct entries.
There is also a script on github which tries to create them for you when the table is corrupt.
github.com/ikajaste/Joomla-2.5-Asset-Weaver

Take a backup of the site before trying any of the above.

Regards,

Rob
  • Robert Went's Avatar
  • Robert Went
  • Moderator
  • 2210 posts
  • 196 Thanks
  • Karma: 90
The administrator has disabled public write access.
You should be able to see the site now. My webhost fixed whatever was going on with the server. I did the rebuild as you suggested.

My menus still don't show what they're supposed to - at least not the layout menu. Also the template images are not showing.
  • Tangier Clarke's Avatar
  • Tangier Clarke
  • 12 Month basic
  • 136 posts
  • Karma: 0
The administrator has disabled public write access.
The site has a very long time to first byte which suggests a problem with the backend.
www.webpagetest.org/result/140107_WF_153F/

If you turn on debug in global configuration then you can check the profile information to see what is taking so long.

The menu seems to be fine for me on the front of the site.
If there is a problem in the admin area then you can open a ticket with super admin details and we can take a look for you.

Regards,

Rob
  • Robert Went's Avatar
  • Robert Went
  • Moderator
  • 2210 posts
  • 196 Thanks
  • Karma: 90
The administrator has disabled public write access.
Hi,

By the looks of it I think this is actually related to the migration / update.

If you can create a ticket with login details we can take a deeper look. It may be that you need to recreate the mega menu structure and perhaps try reinstalling zentools.

If you create the ticket though we will help to point you in the right direction.

Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
That's strange the menu is fine for you. You're not seeing that the layout menu shows two of the same submenus?

My process in setting this up was:

Install Nebula Quickstart
Use J2XML to bring over content and categories
upgrade the Joomla version from the backend.

I know I'll end up customizing the menus, but I just wanted a well functioning quick start page with the images and menus all working so I can at least have that and disable what I don't need.

I'll try your recommendations.
  • Tangier Clarke's Avatar
  • Tangier Clarke
  • 12 Month basic
  • 136 posts
  • Karma: 0
The administrator has disabled public write access.
I can see the double menu. Its just that if the menu was fine before then the new factor is j2xml. I havent used that component before so not sure how it works under the hood.

Keen to see what the issue is.
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
I created a ticket, thank you.
  • Tangier Clarke's Avatar
  • Tangier Clarke
  • 12 Month basic
  • 136 posts
  • Karma: 0
The administrator has disabled public write access.
Understood. Perhaps I should start over. I'd rather not. I spent so much time trying different tools to bring over my content before trying J2XML. I don't know why it affected the template this way, but oh well.
  • Tangier Clarke's Avatar
  • Tangier Clarke
  • 12 Month basic
  • 136 posts
  • Karma: 0
The administrator has disabled public write access.
Can see the ticket on the system

Thanks
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Let us take a look first. Might be something for us to do.

Will post back.
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Found something very interesting tonight. I just did a fresh install on a new database of the Nebula Quickstart found at the link below. The layout menu is showing double the same links. It is not like your live preview. I thought it was something I did by using J2XML and/or updating the Joomla version after installing the quick start package, however that's not the case. This is a fresh install with sample data used. Nothing has been done to the site after that.

nccfc.net/nebulaquickstart2
  • Tangier Clarke's Avatar
  • Tangier Clarke
  • 12 Month basic
  • 136 posts
  • Karma: 0
The administrator has disabled public write access.
Hmm yes sorry I can confirm that now too.

Seems to be a discrepancy with my test package and the download.

I'll get a fix for this.
So sorry for the trouble.
Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Actually just realised the fix is to delete the instance of the mega menu.

1. in the template admin go to the mega menu page.
2. Hit the delete button
3. Save

Now the menu will display fine and you can recreate the menu as you need.

I'll fix the package here so this issue is sorted.

You had some other permission issues on the initial install - do you have the same issues on the test install?
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
All seems well right now. Although the fresh install at http:/nccfc.net/nebulaquickstart2/ seems to take a while to load. Perhaps that's an issue with the hosting company, I am not sure.

So at the moment there's no way to get the same items in the layout menu that you have in your live preview? I wanted to have the template like yours and disable it so that I can reenable it for reference if I need to.
  • Tangier Clarke's Avatar
  • Tangier Clarke
  • 12 Month basic
  • 136 posts
  • Karma: 0
The administrator has disabled public write access.
Unfortunately no.

We initially released the package with K2 but because of the resulting file size some users had trouble with the download. So the end result is that the multiple columns are not needed in the menu.

You can recreate the columns quite quickly though for the others. If you would like us to do that (since this has proved to be our issue) please bump your ticket and I will do that for you.
Thanks
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers