Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Menu does not work with Internet Explorer

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi Paul,

Unfortunately it is IE8. Spoke to one of the head guys in IT yesterday; he says we need to keep IE8 since it is compatible with some of the other programs our scientists use. <sigh> As a non-IT person I don't know if this makes sense or not.

Please let me know whatever time you guys are able to set up a screen share meeting with me… I'll make myself available any time!

Alternatively, I can try any fixes that have previously worked if you guys are willing to share them with me.

Thanks again

BTW confirmed just now that the site works perfectly on IE10.
  • GeraKarafin's Avatar
  • GeraKarafin
  • 6 Month Developer
  • 32 posts
  • Karma: 0
Last Edit: 7 years 5 months ago by GeraKarafin.
The administrator has disabled public write access.
I'll talk to the developers when they are available and get back to you as soon as I can

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Speaking to Anthony is it possible to provide an akeeba backup file of the site so we could then take a look at it locally?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I got my whole company to upgrade from IS 8 to 10 and the menu just doesn't seem to work at all on PC. There is an empty space. VERY FRUSTRATING and confusing. Please help.
  • GeraKarafin's Avatar
  • GeraKarafin
  • 6 Month Developer
  • 32 posts
  • Karma: 0
Last Edit: 6 years 11 months ago by GeraKarafin.
The administrator has disabled public write access.
Do you mean IE10?

Internet Explorer version 10

Do you have a link for the site?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Can you confirm the version numbers of the template and plugin?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Moments v1.4.2
T3 Framework Plugin v2.1.3
T3 Framework Package v1.2.4

Yes, I meant Internet Explorer. Thanks.
  • GeraKarafin's Avatar
  • GeraKarafin
  • 6 Month Developer
  • 32 posts
  • Karma: 0
Last Edit: 6 years 11 months ago by GeraKarafin.
The administrator has disabled public write access.
Do you have a link for the site?

Thanks
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul, It's on a dedicated server, so it's not accessible outside of our company. I will PM you screen shots.
Update: couldn't figure out how to do that so I will post them here.
  • GeraKarafin's Avatar
  • GeraKarafin
  • 6 Month Developer
  • 32 posts
  • Karma: 0
Last Edit: 6 years 11 months ago by GeraKarafin.
The administrator has disabled public write access.
screen_PC.jpg


ScreenShot2014-10-21at6.13.25PM.png
  • GeraKarafin's Avatar
  • GeraKarafin
  • 6 Month Developer
  • 32 posts
  • Karma: 0
The administrator has disabled public write access.
I can see you have created a ticket

Are you able to provide any access via the ticket?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I don't believe so. What has helped others? I am able to edit the php or less files if necessary.
  • GeraKarafin's Avatar
  • GeraKarafin
  • 6 Month Developer
  • 32 posts
  • Karma: 0
The administrator has disabled public write access.
This hasn't cropped up for a long time so I'm surprised you are having problems

Its very hard to troubleshoot a site without seeing the site

Can you confirm you are running IE10 in standards mode?
You've got developer mode disabled?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

How do I run standards mode? Developer mode is disabled.
  • GeraKarafin's Avatar
  • GeraKarafin
  • 6 Month Developer
  • 32 posts
  • Karma: 0
The administrator has disabled public write access.
Can you check out this screenshot

techathlon.com/wp-content/uploads/2012/11/1.jpg
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
And also this page

msdn.microsoft.com/en-gb/library/ie/hh920756(v=vs.85).aspx
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
The following user(s) said Thank You: GeraKarafin
I did this, and doctype appears to be correct.

But you have pinpointed the problem, it's running in IE10 compatibility mode as a default. THANK YOU for pointing me in the right direction. Do you know if there is a way for us to force it to run IE 10 in regular mode?

Thanks again
  • GeraKarafin's Avatar
  • GeraKarafin
  • 6 Month Developer
  • 32 posts
  • Karma: 0
Last Edit: 6 years 10 months ago by GeraKarafin.
The administrator has disabled public write access.
The only way to do this reliably is in a .htaccess file where you can add the following code
<IfModule mod_headers.c>
    Header set X-UA-Compatible "IE=edge"
    <FilesMatch "\.(appcache|atom|bbaw|bmp|crx|css|cur|eot|f4[abpv]|flv|geojson|gif|htc|ico|jpe?g|js|json(ld)?|m4[av]|manifest|map|mp4|oex|og[agv]|opus|otf|pdf|png|rdf|rss|safariextz|svgz?|swf|topojson|tt[cf]|txt|vcard|vcf|vtt|webapp|web[mp]|woff2?|xloc|xml|xpi)$">
        Header unset X-UA-Compatible
    </FilesMatch>
</IfModule>

Regards,

Rob
  • Robert Went's Avatar
  • Robert Went
  • Moderator
  • 2210 posts
  • 196 Thanks
  • Karma: 90
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers