Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Displaying K2 Content transfer from Ignite Template

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi Guys,

Its nearly 12am NZT and I have been tearing my hair out going through the documentation and Forum topics with so much clutter there - so Im going to struggle to not sound impatient with my request - so sorry in advance.

First of all, the documentation is very vague for this template (Moments) because it is written by people who know what they are saying but don't seem to realise that what they are saying is incredibly unspecific.. - you guys seriously need to start producing basic 2 minute Youtube videos on "how to" get to the template looking exactly like the demo page (e.g. exactly step by step) to help visual learners as well. It would help to clean up these boards so much and give us all some time back we could have dearly wanted... Anyway...

I am moving from the Ignite template over to Moments - so I am in need of replacing my Zentools modules in set positions with targeted content from K2 (items) to a position that I can only guess is called abovecontent? Rather than say what I have done so far - I need a very specific, step by step set of instructions in order to have this content from K2 show up on the home page. Imagine that you are speaking to a complete novice please - No stone unturned. I tend to learn best when I can see images; following text tends to drive me nuts therefore I really need good instruction if I am to follow text. So to recap - I am moving over from Ignite - a template that has a whole different set of rules, and NO, I have not managed to get anything showing on the Moments template yet. Thanks.
  • jamesn09's Avatar
  • jamesn09
  • 12 Month basic
  • 21 posts
  • Karma: 0
The administrator has disabled public write access.
Hi

If you go to the general tab in the template settings do you have

Remove mainbody output from homepage - set to yes?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul

No, it is set at "Off"

I must be missing something obvious though...
  • jamesn09's Avatar
  • jamesn09
  • 12 Month basic
  • 21 posts
  • Karma: 0
The administrator has disabled public write access.
Hi James,

We probably need a link to see what's happening here.
I am moving from the Ignite template over to Moments - so I am in need of replacing my Zentools modules in set positions with targeted content from K2 (items) to a position that I can only guess is called abovecontent?

The abovecontent module is hidden if the hide main content is enabled. You need to check that across all template instances. If you move the module to grid1 for instance does it show then?

Or if you are just showing content in the main content area - that will display if you have the menu item setup correctly - eg using a K2 category type menu item and you have the main content not hidden on the front page.

But a link will help you to diagnose the issue.

As far as the documentation goes I assume you have looked here:
docs.joomlabamboo.com/joomla-templates/moments-documentation

and specifically at the diagram showing which modules are used on the front page.

I understand the frustration when you can't find what you need and what's not being made explicit. Writing a step by step guide for this is not feasible in the short term due to our other commitments that we have this week. But we would be happy to point out what's required in your case if you have specific questions and can provide a link so we can see where you are up to.

Doing Youtube tutorials is on my list of tasks but it's taking considerable amount of time to be able to get to them.

Thanks for your feedback.
Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
Last Edit: 6 years 2 weeks ago by manh.
The administrator has disabled public write access.
Hi Anthony

I have clear styling issues, as you can see in the screenshot below:

ScreenShot2015-09-10at11.04.47AM.png


When I looked at the documentation for Moments and hit the tab Frontpage for module positions etc, all it showed me was the below black space titled "Joomla Featured Content" without specifying the kind of module (I'm assuming Zentools) and how to adjust the parameters so that everything fits just as your demo page shows things to fit.

ScreenShot2015-09-10at10.34.12AM.png


In my case, in order to duplicate the layout of the demo page do I need to make the styling changes in the Zentools module or does it need to be in the K2 Categories section? In particular, with the demo page I like how there is no vertical space between the articles and those that fall directly beneath them - it's a nice aesthetic and adds to the flow of a stream where new content can continually be introduced at the from the top of the page like a waterfall.

I guess what I'm trying to say when I mention that I need step by step instructions - perhaps it's just a checklist of basic things that most skilled people would take for granted but perhaps less skilled people wouldn't - I don't know. But every time when I am trying to make what should be a simple change, I run into missteps that end up turning a molehill into a mountain for me, and lots of time wasted going back and forth scouring forum boards and tutorials trying to find a direct outcome which is to essentially copy the demo page. Cheers
  • jamesn09's Avatar
  • jamesn09
  • 12 Month basic
  • 21 posts
  • Karma: 0
The administrator has disabled public write access.
Ah ok - that black space that says Joomla featured content means the menu item for the front page uses the featured menu item.

To render K2 content and that styling it's still the main content but you need to use the Zenkit filter like this page:

bambootheme.com/showcase/jun13/k2-zenkit/filter

1. Install Zenkit
2. Assign your K2 categories to the filter template
3. Make the home menu item a blog category for K2 that points to that category.

That should get you started.
Thanks
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Hey Anthony,

1) and 2), ok. 3) Not ok. After going to menu manager and opening the Main Menu, Clicking Menu Item Type --> K2--> From there I could not find anything resembling a blog category. There was a user blog, but that was completely different.

Anyway sorry for sounding impatient but... my learning curve is clearly too big, I am mainly interested in having a working site that I can add content to not in how to do it... how do I pay somebody to get this done for me?

Not only do I need my site to look like the demo site, but also I want a Japanese Language button (and English language button) so I can produce the content in two languages. I've successfully done this before but my memory has been wiped on how I did it and I can't really be bothered teaching myself something again that I will probably forget anyway.

If it is easiest to just copy the demo site content to my own site for it to be constructed, I am happy to do that if its easiest for you guys. I can then replace that content with my own as I go.
  • jamesn09's Avatar
  • jamesn09
  • 12 Month basic
  • 21 posts
  • Karma: 0
The administrator has disabled public write access.
Hi,

Sorry I meant K2 > categories.

1. Then go to the options tab.
2. Select the categories you want to display (which you have assigned the filter template to.)
3. Click Save.

That kind of stuff is probably more about understanding the way that Joomla works and specifically how to assign content to pages using K2.

We can certainly help you to do this but I need to check with Rob regarding his availability as I am fully booked for the rest of the week.

Rob is on UK time and wont be around for another 12 hours, so in the meantime I would recommend downloading the quickstart package and checking settings there as a reference. Or if you have content that you can add then perhaps focus on that and wait for Rob to come back to you.

I totally hear you regarding the learning curve and where you want to spend your time. Joomla is a complicated system that allows you to do powerful things but that complexity and power does come at a price.

Thanks Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Hi Anthony

I replaced my site with the quickstart package and sample data - I pretty much destroyed what I had and started again.

I need to explore the settings and try to shift some of my own content back in, then once I sense I'm getting closer to asking, I will set up another ticket and register for some help. Thanks for the suggestion.
  • jamesn09's Avatar
  • jamesn09
  • 12 Month basic
  • 21 posts
  • Karma: 0
The administrator has disabled public write access.
Hi

Is there anything I can help you with at this point?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul sorry for the late reply I've been away for the last few days at a sports tournament.

So what I've done is download the quickstart version with sample data, hoping to gradually replace that content with my own content. However, whenever going into categories or articles it does not let me save them in their altered state. Is there something that I need to disable or re-enable in order to do this?

Thanks
  • jamesn09's Avatar
  • jamesn09
  • 12 Month basic
  • 21 posts
  • Karma: 0
The administrator has disabled public write access.
Hello again :)

So I basically got out of Google Chrome, logged on to Firefox and tried again and it worked. A bit odd, but thankfully for now that issue is solved so long as I stay on Firefox.

For now it's great - I can focus on content for a while - my understanding of the system could definitely be better, but by doing these manual changes hopefully my mind will come around a bit. But as I mentioned to Anthony, the next time I get in touch it will be to purchase a technical block in an area where I'm better off delegating that responsibility rather than stressing out about it. Cheers.
  • jamesn09's Avatar
  • jamesn09
  • 12 Month basic
  • 21 posts
  • Karma: 0
The administrator has disabled public write access.
Thanks for the update

That does sound a bit odd with Chrome - did you try clearing the browser cache?

Sometimes after a Joomla update odd things can happen

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

I cleared the cache and that seems to have done the trick, however, I have noticed a content issue with regards to embedding video. For some reason, when I open an article and go into the source code - any video that I might embed for some reason does not save and does not even show up when I toggle back out of the source code into the WYSIWYG interface. I've used various editors, Tiny, CodeMirror and JCE, however, neither of those mitigates this problem. Advice would be much appreciated, thanks.
  • jamesn09's Avatar
  • jamesn09
  • 12 Month basic
  • 21 posts
  • Karma: 0
The administrator has disabled public write access.
Hi

If its JCE it can be overridden

In the JCE Control Panel, click on the Editor Profiles button.

Click on the Profile name that the user, usergroup or component is assigned to, eg: 'Default'

Click on the Plugin Parameters tab, then on the Media Support tab.

Check that the Allow IFrames is set to Yes.

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Also if using RS Firewall it can mess up the tags I think
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Yeah I just googled to check on the text I had stored

www.joomlacontenteditor.net/support/faq/item/iframe-removed-on-saving

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
The following user(s) said Thank You: jamesn09
Hi there again

I've been searching for 2 hours, so thought i would finally come back to this thread... The home page for "Moments" sources information that is "articles" sourced, not K2. This presents 9 featured articles from the Joomla articles section. My question is, what is the name of the module that helps present these articles onto the home page? K2 uses Zenkit, but I have no idea what Joomla articles uses to display article intros onto the home page... is it a zentools module? If so, what is its name?
  • jamesn09's Avatar
  • jamesn09
  • 12 Month basic
  • 21 posts
  • Karma: 0
The administrator has disabled public write access.
Hi

You have the content content in k2 organised?
You have the k2 category options set?

For the menu link set the k2 to k2 categories and chose the categories you want to select

Chose the options for that layout e.g. columns

How do you have the template style set up? - what layout is being used?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
Last Edit: 6 years 1 week ago by manh.
The administrator has disabled public write access.
Once you have that - can you post a link for the site

I think we may need to advise some styling

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers