Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Links from the Grid to Single Articles

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi JB Team:

I have just upgraded one of the sites that I care take from J1.5 to J3.0...
The grid on the Home Page has nine sections and each is supposed to link the article specifically... However, it just goes back to the Home Page...

paacl.ca/j25/

I notice that the link includes a reference to the home page... Here is an example of the link that appears at the bottom of the browser...

paacl.ca/j25/43-home-page/88-diversity-at-work/

Obviously the 43-home-page is responsible for taking the link back to the home page instead of 88-diversity-at-work... the actual article...

How can this be corrected for all of the grid links...??
Thanks,

Tony
  • Tony Shaw's Avatar
  • Tony Shaw
  • LIfetime Developer - Big Bamboo
  • 1908 posts
  • 9 Thanks
  • Karma: 13
The administrator has disabled public write access.
Not quite sure I follow - do you have valid menu links for the grid articles - can be a hidden menu but you need a menu link some where

As this sounds like a menu id issue

www.joomlabamboo.com/blog/tutorials/how-to-avoid-the-joomla-menu-itemid-issue
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
HI Paul:
The links were created using sp upgrade when I upgraded the site from 1.5 to 3.0
If you hover over an individual tile in the grid - it takes you back to the home page...
I will look at the link you sent before I do any more on this...

Cheers for now!
Tony
  • Tony Shaw's Avatar
  • Tony Shaw
  • LIfetime Developer - Big Bamboo
  • 1908 posts
  • 9 Thanks
  • Karma: 13
The administrator has disabled public write access.
I just read this Paul, I don't think this is the issue...
I will send more info!
Tony
  • Tony Shaw's Avatar
  • Tony Shaw
  • LIfetime Developer - Big Bamboo
  • 1908 posts
  • 9 Thanks
  • Karma: 13
The administrator has disabled public write access.
hoverresult.png

Hi Paul:

Here is a screen shot of what happens when I hover over Your Home... notice that at the bottom of the page, the link it will connect to is visible as:

paacl.ca/j25/43-home-page/programs/228-your-home

Word programs refers to the category, and the 228-your-home is the specific article

Why does 43-home-page appear in that link....
Does this explain the problem more?

Thank you,
Tony
  • Tony Shaw's Avatar
  • Tony Shaw
  • LIfetime Developer - Big Bamboo
  • 1908 posts
  • 9 Thanks
  • Karma: 13
Last Edit: 8 years 2 months ago by Tony Shaw. Reason: forgot the file addition
The administrator has disabled public write access.
So on the site is there a valid published menu link for either the category or the individual articles?

I'm looking on the site and I can't see them or do you have a hidden menu for them?

Try adding an item that is on the main menu that you know works and see if that works via the grid

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul:

"So on the site is there a valid published menu link for either the category or the individual articles?"

Each individual article has a menu link... that is what is so puzzling...

"I'm looking on the site and I can't see them or do you have a hidden menu for them?"

They are under the Services menu item.

Not sure what you mean by adding an item that is on the main menu...
Take a look at this from the 1.5 site...

www.paacl.ca
I was hoping that it would work the same way...

Tony
  • Tony Shaw's Avatar
  • Tony Shaw
  • LIfetime Developer - Big Bamboo
  • 1908 posts
  • 9 Thanks
  • Karma: 13
The administrator has disabled public write access.
Hi Paul:

I have finally figured this out... the upgrade has made some 'changes' and the links are following those changes. I am re-writing the menus... and getting them to work normally.

Cheers,
Tony
  • Tony Shaw's Avatar
  • Tony Shaw
  • LIfetime Developer - Big Bamboo
  • 1908 posts
  • 9 Thanks
  • Karma: 13
The administrator has disabled public write access.
ah that would explain it

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul...
Yes, but not an easy task!
I will report when I am done... to let you know. It might just help others...
B)
Tony
  • Tony Shaw's Avatar
  • Tony Shaw
  • LIfetime Developer - Big Bamboo
  • 1908 posts
  • 9 Thanks
  • Karma: 13
The administrator has disabled public write access.
Good luck with it

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
HI Paul:

Well, I guess that SP Upgrade does make some changes... I did recreate the menu items and of course they work like a JB Charm!

www.paacl.ca/j25

Thanks again for your help...

tony
  • Tony Shaw's Avatar
  • Tony Shaw
  • LIfetime Developer - Big Bamboo
  • 1908 posts
  • 9 Thanks
  • Karma: 13
The administrator has disabled public write access.
Thanks TOny
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Hi Anthony... Paul is amazing!:woohoo:
Tony
  • Tony Shaw's Avatar
  • Tony Shaw
  • LIfetime Developer - Big Bamboo
  • 1908 posts
  • 9 Thanks
  • Karma: 13
The administrator has disabled public write access.
You're welcome

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers