Support Forum

  • Page:
  • 1
  • 2

Tweets not showing up in JTweet

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi guys,

I have been using JTweet and when I first installed it all was fine. A few days ago it stopped displaying my tweets and I cannot get it to work properly. I read the various discussions on this forum about others with similar problem, but these all go back a year or 2. I reloaded JBlibrary, tried changing various parameters as discussed, but nothing worked. Setting "Display your tweets or query?" to Your tweets completely disables everything, but setting it to Twitter Query or Multi-User Tweets at least loads the link to the twitter page.
Here is a link to the development site:
www.bespokeshoesforwomen.co.uk/personal/index.php/contact-us

I am working with Joomla 1.7 and have JB library 1.2.0 enabled.

Any ideas

Thank
Richard
  • Richard's Avatar
  • Richard
  • LIfetime Developer - Big Bamboo
  • 95 posts
  • Karma: 0
The administrator has disabled public write access.
Do you use cache?

maybe you can clean the 'server' cache via maintenance cache.
  • Bert de Boer's Avatar
  • Bert de Boer
  • Free Extensions
  • 229 posts
  • 25 Thanks
  • Karma: 20
The administrator has disabled public write access.
Hi Bert

I cleared out the server cache as you suggested, but still no tweets. I think it has something to do with jquery but I cannot see where I have loaded it elsewhere that would cause this problem. The only thing I recall changing recently was installing 1.0.5 of zentools. I am stumped.

Richard
  • Richard's Avatar
  • Richard
  • LIfetime Developer - Big Bamboo
  • 95 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Richard,

Have you updated as well to the lastest version of JTweet 1.8.0. May be this solves it.

And did you check in modules/mod_zentools/js the existance of jquery.tweet.js?
  • Bert de Boer's Avatar
  • Bert de Boer
  • Free Extensions
  • 229 posts
  • 25 Thanks
  • Karma: 20
The administrator has disabled public write access.
Hi Richard,

Could you post a shot of your jTweet settings? I don't see the module making any calls to Twitter, so wondering if it is a settings issue.

Thanks.
  • Seth's Avatar
  • Seth
  • Moderator
  • 8358 posts
  • 225 Thanks
  • Karma: 202
The administrator has disabled public write access.
Hi Seth,

To confirm I am using jTweet 1.8.1 and Joomla 1.7. I have modified all of the parameters to see if I can get some tweets, but nothing, I agree that it sounds like a jquery issue.

Here are the screenshots of the settings

Richard
  • Richard's Avatar
  • Richard
  • LIfetime Developer - Big Bamboo
  • 95 posts
  • Karma: 0
The administrator has disabled public write access.
You just need to set the module to display your tweets, not a query, and then insert your Twitter ID where is says Joomlabamboo currently.
  • Seth's Avatar
  • Seth
  • Moderator
  • 8358 posts
  • 225 Thanks
  • Karma: 202
The administrator has disabled public write access.
If only it were that simple Seth. I only put joomlabamboo in there to make sure that there were no permissions problems with our twitter account. Eariler I explained that when set to "your tweets" nothing works, the link does not even take you to our twitter account. When set to query or multi-user the link works even though it does not display any tweets.

I have just put in a third party module that displays our tweets fine so it looks like the twitter server is working fine.

I have reinstalled jtweet and jblibrary but this had no effect either.

Can you think of anything else I can try.

Cheers
Richard
  • Richard's Avatar
  • Richard
  • LIfetime Developer - Big Bamboo
  • 95 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Richard,

Looks like you have another module on the page now.

We will need it to be published to trouble shoot this one as it sounds like a javascript error. I have it working with this template here.

Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Hi Anthony,

Your presence is enough to resolve my issue yet again! I noticed that in the K2 parameters, I was also loading jquery. I set this not to load and JTweet came alive.

I do not really understand what happened, can you explain it to me? It appeared that JTweet and K2 were loading the same jquery library, but it stopped tTweet from working. Can you throw any light on this for me so I can avoid the situation in future?

Thanks
Richard
  • Richard's Avatar
  • Richard
  • LIfetime Developer - Big Bamboo
  • 95 posts
  • Karma: 0
The administrator has disabled public write access.
Hehe.

Well if you load the same version of JQuery from Google it doesn't matter how many times you have it referenced as Google intelligently figures out that you only need one. Otherwise if you have multiple versions of jQuery loading from multiple sources you end up with JS conflicts.

Hope that helps.

Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
The following user(s) said Thank You: Richard
I have exactly the same problem... :(

www.berserker.com.br/index.php

Take a look (left side)...
Twitter Feed works.
JTweet dont...
The joomla is 1.7 - JA Travel template (joomlart with T3 framework v2)

I followed the instructions above, but nothing until now...
Can you helpme?

Tks!
  • maricate's Avatar
  • maricate
  • JB Pro
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
Hey Tiago,

I'm still getting a 404 error on your link.

Can you confirm please?

Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Sorry... now the linlk works...
Check the left side...
  • maricate's Avatar
  • maricate
  • JB Pro
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
You have two versions of jQuery loading on the page while you only need one.

Not sure if the versions you have will load on all pages though as they appear to be attached to modules.

You will need to install the JB Library plugin to have jQuery referenced across all pages if that is the case.

Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Hi Anthony!
Thank for your attention...
JB library was intalled and enabled now...
But the module does not work yeat and the effects of the main menu stop working.
If you want, I can create a administrator login for you...
I do not know if I'm doing things right.

Tks again!
  • maricate's Avatar
  • maricate
  • JB Pro
  • 7 posts
  • Karma: 0
Last Edit: 8 years 4 months ago by maricate.
The administrator has disabled public write access.
You now have three versions of jQuery loading - you only need one.

The issue isn't with the module its because the other modules are also loading jQuery.
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
I have no idea what I should do. :(
I've tried to install plugins that solve incompatibility between versions of jQuery, but all that did not work.
  • maricate's Avatar
  • maricate
  • JB Pro
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
You need to stop jQuery from loading from the other modules. I would contact the developers of those extensions to se show to do this if there isn't a toggle in the module already.

The two extensions that are loading it are:

JAPopup
www.berserker.com.br/plugins/system/japopup/fancybox/js/jquery-1.3.2.min.js

and

AutosonSlideshow
www.berserker.com.br/modules/mod_AutsonSlideShow/js/jquery-1.5.2.min.js

Thanks
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Hi Anthony...
I have disabled JApopup plugin and the AutosonSlideShow and the JTweet works!
:)
But... Is there any way to put multiple modules that use jQuery to work together?
After I enable the JB library, menu effects stop to work.
Or I have to choose just one module?
  • maricate's Avatar
  • maricate
  • JB Pro
  • 7 posts
  • Karma: 0
Last Edit: 8 years 4 months ago by maricate.
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers