Support Forum

JB Maps, preventing full SSL on site.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

HI folks, Happy Monday!

I just added SSL to this Joomla site: carriagehillsoa.ca/

You'll notice that I'm getting an grey padlock. Upon investigation, it appears to be caused by mixed content. Specifically, the marker.png image as reported by the Inspector.... part of the JB MAPS module.

Warning from Google Chrome's Inspector:"

util.js:30 Mixed Content: The page at 'carriagehillsoa.ca/' was loaded over HTTPS, but requested an insecure image 'maps.google.com/mapfiles/marker.png'. This content should also be served over HTTPS.

I can't find the source of the http ref (not https) of the marker file. I can only determine that it's from a .js file from. A JB JS file?

I also updated JP MAPS with the latest version... id didn't make a difference.

I look forward to hearing from you,
Gilles
  • gg008's Avatar
  • gg008
  • 12 Month basic
  • 124 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Giles,

Can I just check are you using jbmaps or jbmaps2?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Maps2 Paul...
Gilles
  • gg008's Avatar
  • gg008
  • 12 Month basic
  • 124 posts
  • Karma: 0
The administrator has disabled public write access.
What happens when no marker is used on the map?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,
I can't find where to set "no marker" in the module.
Where is this?

Gilles
  • gg008's Avatar
  • gg008
  • 12 Month basic
  • 124 posts
  • Karma: 0
The administrator has disabled public write access.
Is it possib;e Maps2 is using "old" code?

I hope to hear from you soon as my client is wondering why the green lock isn't appearing on the home page :(

Cheers!
Gilles
  • gg008's Avatar
  • gg008
  • 12 Month basic
  • 124 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Giles,

Are you using the latest version of the jbmaps2 module?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
2017-10-31_21h14_21.png


Marker section

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
try changing the icon path to https

See if that works

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,
I don't see what you see at all. and yes... I installed the latest from the website (free version as I don't have a subscription
Screenshot-2017-10-31Modulesmod_jbmaps2-CarriageHillsOwnersAssociation-Administration.png

)
  • gg008's Avatar
  • gg008
  • 12 Month basic
  • 124 posts
  • Karma: 0
The administrator has disabled public write access.
That pic doesn't match the site as I can still see a marker

caching enabled?

The is only a free version we don't offer a paid version of this extension

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,

Caching is disabled on the site due to another issue caching creates.

What you see is indeed the module . If I disable it, the map disappears from the home page.

and I get a green padlock, full ssl, on the page.
Gilles
  • gg008's Avatar
  • gg008
  • 12 Month basic
  • 124 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Giles,

The module screen you added has no markers listed

But the site module is still displaying a marker

2017-10-31_22h15_58.png


Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Yes, Paul, that is correct. I don't understand either. But this is definitely the module.

I just downloaded (again) the module from the JB site, installed it. Oddly, it installs both maps and maps2. I deleted maps.

Doesn't make a difference, I still see the screen shown in the screenshot I provided.
Gilles
  • gg008's Avatar
  • gg008
  • 12 Month basic
  • 124 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Giles,

Have you tried disabling this module

Creating a new one without a marker and saving?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
OK... I just tried, and as expected... it works... green padlock because the marker image isn't called with https, (http... causing the mixed content error)

Can this not be fixed in the module code, by issuing a new release?

By the way, in the new module I created, the only thing which appears in the Makers tab is:


Info Window Behaviour
Markers
Marker fields will appear here after adding a marker by clicking on the map

Is this not weird?
  • gg008's Avatar
  • gg008
  • 12 Month basic
  • 124 posts
  • Karma: 0
Last Edit: 2 years 3 months ago by gg008.
The administrator has disabled public write access.
Also,.. nothing at all happens when I click on the "map preview" in the Module tab. Just a big white space.

and "location search" doesn't appear to do anything either.
  • gg008's Avatar
  • gg008
  • 12 Month basic
  • 124 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Giles,

Have you tried adding an s to the path to the icon marker image?

as per the screenshot above

www.joomlabamboo.com/media/kunena/attachments/19938/2017-10-31_21h14_21.png
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
regarding preview

do you not have a map displaying?

2017-11-01_01h49_03.png


I think search is a bit buggy Google wise in the settings
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul,
As mentioned, I don't see the marker url at all. all i see is:

Info Window Behaviour
Markers
Marker fields will appear here after adding a marker by clicking on the map

that's it! nothing. so I can't change the URL ..it's not there :(

and in preview... I don't see a map... just a big blank space.
Back to you...
  • gg008's Avatar
  • gg008
  • 12 Month basic
  • 124 posts
  • Karma: 0
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers