Support Forum

  • Page:
  • 1
  • 2

Images not displaying

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi guys,

I'm having problem with this module. It isn't displaying images. I tried the other solutions in the forum including setting images/stories directory permissions 755, confirming the modules files permission are 644 and it still wont display.

I have attached a document with the images of the problem.

I have used this lovely module B) before with no problem. This is the first time I'm experiencing anomalies :unsure: . Will highly appreciate any help.

Thanks!!
  • Ephraim Muchemi's Avatar
  • Ephraim Muchemi
  • Free Extensions
  • 8 posts
  • Karma: 0
The administrator has disabled public write access.
Have a link ?
  • tornado's Avatar
  • tornado
  • 12 Month basic
  • 139 posts
  • Karma: 2
The administrator has disabled public write access.
the link is
www.mediacouncil.or.ke/index.php?option=com_content&view=article&id=61&Itemid=12

The grey area below the article is where the module is supposed to display
  • Ephraim Muchemi's Avatar
  • Ephraim Muchemi
  • Free Extensions
  • 8 posts
  • Karma: 0
The administrator has disabled public write access.
You don't appear to have any content set to display there. Captify is running, but it has nothing to display. Please check that you have assigned a source category with items that contain images. Thanks.
  • Seth's Avatar
  • Seth
  • Moderator
  • 8358 posts
  • 225 Thanks
  • Karma: 202
The administrator has disabled public write access.
Hi Seth,

I had already assigned source category with items that contain images (please find attached document with pint screens of the module and plug-in). That is what I am fumbled about.
  • Ephraim Muchemi's Avatar
  • Ephraim Muchemi
  • Free Extensions
  • 8 posts
  • Karma: 0
The administrator has disabled public write access.
Sorry...Document didn't attach. pls click the following links
  • Ephraim Muchemi's Avatar
  • Ephraim Muchemi
  • Free Extensions
  • 8 posts
  • Karma: 0
Last Edit: 10 years 7 months ago by Ephraim Muchemi.
The administrator has disabled public write access.
Nothing attached, but you can just attach an image directly....
  • Seth's Avatar
  • Seth
  • Moderator
  • 8358 posts
  • 225 Thanks
  • Karma: 202
The administrator has disabled public write access.
Please find below links to the images & PDF document

Page intended to display Captify Content module: www.mediacouncil.or.ke/images/Captify%20Content%201.JPG

Administrator Module Manager: www.mediacouncil.or.ke/images/Captify%20Content%202.jpg

Administrator Plugin Manager: www.mediacouncil.or.ke/images/Captify%20Content%203.jpg

PDF Document with all the above: www.mediacouncil.or.ke/images/Captify%20Content%20problem.pdf

Hope this works now.
  • Ephraim Muchemi's Avatar
  • Ephraim Muchemi
  • Free Extensions
  • 8 posts
  • Karma: 0
The administrator has disabled public write access.
OK, you want to display the articles in the category 'code of conduct', so you have to switch the source from Joomla categories to Joomla articles.
  • Seth's Avatar
  • Seth
  • Moderator
  • 8358 posts
  • 225 Thanks
  • Karma: 202
The administrator has disabled public write access.
Thanks Seth....clearly I need a break...

Now it is displaying the article titles but not the images....Please find link below

www.mediacouncil.or.ke/index.php?option=com_content&view=article&id=61&Itemid=12
  • Ephraim Muchemi's Avatar
  • Ephraim Muchemi
  • Free Extensions
  • 8 posts
  • Karma: 0
The administrator has disabled public write access.
Hi there ... I have the same problem on my website.

Captify content displays titles but not images. Images are assigned ...

www.agapewebdesign.net/index.php?option=com_content&view=article&id=1&Itemid=2

Fotografia, grafica, loghi etc are the links of the categories .
  • Natalia's Avatar
  • Natalia
  • Free Extensions
  • 17 posts
  • Karma: 0
The administrator has disabled public write access.
You have error 500 on the image links, most certainly a permissions issue. Are you folders (notably /modules/mod_captifycontent/imagecache) 777?
  • Seth's Avatar
  • Seth
  • Moderator
  • 8358 posts
  • 225 Thanks
  • Karma: 202
The administrator has disabled public write access.
@flyfi
@natalia

You both have the same issue.

@flyfi - if you have set to 755 already, see if it will work with 777. If it does, it is a sign that your files are not owned by the unix user that Joomla is running under. It is better not to continue with 777 permissions, but get the file ownership fixed. If you don't know how to chown files you should speak to your host.
  • Seth's Avatar
  • Seth
  • Moderator
  • 8358 posts
  • 225 Thanks
  • Karma: 202
The administrator has disabled public write access.
You can find a full discussion of the issue of permissions here:

www.joomlabamboo.com/forum/joomla-security/11385-correct-permissions-for-captify-prettyslider-etc
  • Seth's Avatar
  • Seth
  • Moderator
  • 8358 posts
  • 225 Thanks
  • Karma: 202
The administrator has disabled public write access.
I have put 777 permission now and it doesn't work... Thanks anyway
  • Natalia's Avatar
  • Natalia
  • Free Extensions
  • 17 posts
  • Karma: 0
The administrator has disabled public write access.
@Natalia I get a 500 error when trying to view this image:

www.agapewebdesign.net/modules/mod_captifyContent/image.php?width=200&160&cropratio=7:6&image=/images/stories/amethyst2.jpg

So it means that a folder or file has 777 set as the permissions. This is a security setting in most hosts. The fix for incorrect permissions on the image resizer is that the imagecache folder should be set to 777 if the images dont render if they are set at 755. Once they have rendered then they need to be set back to 755 to make your site secure.

Cheers Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Thanks Seth for prior help and Thank you Anthony for the assistance

Sadly images still not appearing. Will communicate with host over the issue. Hope it works.

Thanks
  • Ephraim Muchemi's Avatar
  • Ephraim Muchemi
  • Free Extensions
  • 8 posts
  • Karma: 0
The administrator has disabled public write access.
Now I have put permissions to 755 and it works!!!!! Great! Thank you for your support! :D
  • Natalia's Avatar
  • Natalia
  • Free Extensions
  • 17 posts
  • Karma: 0
The administrator has disabled public write access.
@Natalia Awesome :)

@Ephraim what permissions are on this file: www.mediacouncil.or.ke/modules/mod_captifyContent/image.php
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Permission is 644
  • Ephraim Muchemi's Avatar
  • Ephraim Muchemi
  • Free Extensions
  • 8 posts
  • Karma: 0
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers