Support Forum

  • Page:
  • 1

Captify needs refresh to appear

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Greetings,
I haven't found any similar topics for this problem so I'm starting a new one.
I'm using Captify Content 1.1.13 on two separate Joomla 2.5.13 installations.
The problem that I am trying to figure out for both sites is that when a user accesses the webpage for the first time captify doesn't load. Nothing appears where captify should appear, except when the user hits refresh. Then captify loads up just fine.

Any ideas? :dry:
  • rinenweb's Avatar
  • rinenweb
  • JB Pro
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
Do you have a link for a site?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Yes, it's www.rinenweb.eu/
(i hope i can edit this post afterwards, since it's a temporary link)
  • rinenweb's Avatar
  • rinenweb
  • JB Pro
  • 7 posts
  • Karma: 0
Last Edit: 6 years 6 months ago by rinenweb. Reason: url change
The administrator has disabled public write access.
Hi

something very strange going on here - there is no content in the body at all when the page loads in Chrome

The js is showing zero width and height for the images

Are you seeing any issues relating to the upgrade?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
No, I haven't had any other problems, mainly because I don't use any other 3rd party extensions - it' s a pretty simple online portfolio.

What if the captify module had an option to "prepare content" like the others? Could it work?

Please let me know if you need access to the back-end...
  • rinenweb's Avatar
  • rinenweb
  • JB Pro
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
Hi

Can you try diabling the colour picker to see if that resolves the js issues and what is the php memory limit on the site?

Regards
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I think i solved it by setting the use of script loader to Yes in the JB Library Plugin (which also moves all the other scripts to the bottom).

If you can confirm it, then I think we 're good! :)
  • rinenweb's Avatar
  • rinenweb
  • JB Pro
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
Yep looks good

Thanks for the update not seen a site do this before

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Well, to be honest, now that I moved the upgraded installation to the main domain, it still needs refresh to appear sometimes... though it's not that frequent now. :dry:
  • rinenweb's Avatar
  • rinenweb
  • JB Pro
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
Hi

It seems ok to me

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Greetings,
I know it's been some time now, but I still haven't figured out what's causing captify not to load sometimes.

I have even tried a script to auto reload the home page once it's loaded (see above code), but this workaround doesn't seem to solve the problem either (actually i think it made it worse).
$(document).ready(function(){

//Check if the current URL contains '#'
if(document.URL.indexOf("#")==-1)
{
// Set the URL to whatever it was plus "#".
url = document.URL+"#";
location = "#";

//Reload the page
location.reload(true);

}
});
  • rinenweb's Avatar
  • rinenweb
  • JB Pro
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
Have you tried changing the jquery version loading and as a test switching to a joomla default install template?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I installed the jQuery Easy plugin which is supposed to solve any conflicts and/or use the latest version of jQuery, but nothing changed.
In fact, I have set my template to not load the jQuery library, so it can't be a template issue either. Nevertheless I also tested with a different template (the default beez20 joomla template) as you suggested, but the problem remains.

I honestly don't have a clue as to why it is happening, although it's probably a script issue.
  • rinenweb's Avatar
  • rinenweb
  • JB Pro
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
At the moment it doesn't appear to be working at all

Captify won't work with that version of jquery - can you try loading a lower version 1.7 and below
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers