Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

Zentools2 Issue with lightbox

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi Friends,
I am having a problem with a Zentools2 module published in Buildr below position, grid, content link lightbox
www.bruce-king.com

For some reason, the lightbox gives 2 copies of the image, one the size designated in the grid layout, and the other the size originally in the article referenced. How can I

1. Get rid of the smaller image in the lightbox, only showing the larger one

2. Get the layout of the lightbox to reflect more accurately the content of the article referenced? Right now, the copy, which I'd like positioned to the left of the copy, appears below in a narrow column, and it looks sort of dumb, since the width of the light box is 100%.

Is there a way to determine the width and height of the lightbox? And how do I get the text to display the way it appears in the article?

Thanks, you guys are the best.
  • swellking's Avatar
  • swellking
  • 12 Month basic
  • 420 posts
  • 1 Thanks
  • Karma: 1
The administrator has disabled public write access.
Hi There,

Are you using the latest module version?

Can you attach a screenshot of the options set to display in the module settings

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I am running the latest version, 2.2.6

I am trying to put the same module in two different sites, and they are both doing the same thing.

ScreenShot2016-07-24at9.50.30AM.png


ScreenShot2016-07-24at9.59.33AM.png


ScreenShot2016-07-24at9.59.45AM.png


ScreenShot2016-07-24at10.00.09AM.png
Attachments:
  • swellking's Avatar
  • swellking
  • 12 Month basic
  • 420 posts
  • 1 Thanks
  • Karma: 1
The administrator has disabled public write access.
Hi

Are you using intro text in the articles?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
No, the articles are just the images 300x300px with text to the right.
  • swellking's Avatar
  • swellking
  • 12 Month basic
  • 420 posts
  • 1 Thanks
  • Karma: 1
The administrator has disabled public write access.
Are you using the article image?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Yes, I created an article for each item in the module, 300x300px, with text. Saved all to category and tag, as category selection in the module sometimes doesn't pick up the content.

Lightbox, image setting in options, selected image only to render in the module, then link to content. Regardless of whether I use tag content or joomla category as content source, the same problem comes up, two copies of the image come up, and the text renders in a really unfortunate narrow column below the smaller image.

Here is what the article looks like, and then how it is rendered in the module

ScreenShot2016-07-25at9.52.47AM.png



ScreenShot2016-07-25at9.54.06AM.png
  • swellking's Avatar
  • swellking
  • 12 Month basic
  • 420 posts
  • 1 Thanks
  • Karma: 1
Last Edit: 3 years 3 weeks ago by swellking.
The administrator has disabled public write access.
If you switch from image to introtext in the module - does that help with the content that displays?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Well, removing image and putting in introtext does get rid of the second image in the lightbox, but there is no text at all.
  • swellking's Avatar
  • swellking
  • 12 Month basic
  • 420 posts
  • 1 Thanks
  • Karma: 1
The administrator has disabled public write access.
sorry I meant fulltext not introtext

Try fulltext instead

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Now I'm also having trouble with slider modules, the slider does not work
And I tried fulltext as well with no results
  • swellking's Avatar
  • swellking
  • 12 Month basic
  • 420 posts
  • 1 Thanks
  • Karma: 1
The administrator has disabled public write access.
Do you images added here to the articles?

article-edit.png
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Regarding the slider modules which pages are they on?
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Sliders did finally render... I'm working on bruce-king.com/ecobuildnetwork.org

But there is a new module problem, and that is that I can't find belowcontent in the list of positions when creating or editing a module, and I really need belowcontent.

It shows up loud and clear in the template manager buildr, I even tried moving it in with main content to see if that would make a difference.

Something is seriously wonky with the module thing and buildr Can you tell me exactly which downloads I should have installed for it and I can try reinstalling them?
  • swellking's Avatar
  • swellking
  • 12 Month basic
  • 420 posts
  • 1 Thanks
  • Karma: 1
The administrator has disabled public write access.
Slider wise it looks like you have some big image sizes given the time it takes to progressively render the first image I see

Perhaps adjust the image size and see if it performs better?

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I use this free service

kraken.io/web-interface

Cheers
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Can you open a new thread for the missing position - help avoid confusion

Cheers
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Regarding the lightbox - probably easier I think if you create a ticket with super admin access and mark it for paul

I can then have a look

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
will do, thanks
  • swellking's Avatar
  • swellking
  • 12 Month basic
  • 420 posts
  • 1 Thanks
  • Karma: 1
The administrator has disabled public write access.
No problem

Give me a prod when it's created

Cheers
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers