Support Forum

  • Page:
  • 1

Confirming - don't us JBLib if using ZGF2?

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

I see updates to JB Library, and it has options I miss (like JQuery suppression), so i want to confirm that I shouldn't install JB Library if a site is Zen Grid Framework 2?

A couple of sites I help with have been affected by the recent Google CDN JQuery update. One of them is zgf1+jbLib and I was able to fix in a single click with JBLibrary.
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
Last Edit: 7 years 2 months ago by blueshift.
The administrator has disabled public write access.
Yes that is correct for Framework v2

With new templates from grid3 onwards however due to switching to a new framework jblibrary will be required

In the framework v2 there is the option of stripping scripts if required

Yes lots of sites have been affected by this update you are not alone

Thanks
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I'm using JQuery 1.7 local on this site, but it's still broken. What can you see with your x-ray vision?

www.duncandouglasmccallum.com/index.php/work#
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
The administrator has disabled public write access.
Hi

I have a problem with all your sites for some reason I just can't load one site - no real idea why

Other members of the team can :)

If you haven't already try loading direct from Google

Thanks
Paul
  • manh's Avatar
  • manh
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I was loading from google...isn;t that what broke it? anyway, it's still busted.
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
The administrator has disabled public write access.
But don't load latest from google, instead load specified version.

About JB LIbrary, in general yes, don't use it together.
But true is that there is new possibility to run it together with ZenGridFramework, but setting is still a bit tricky and you need to test it.

Look here: docs.joomlabamboo.com/templates/2013-template/grid3-documentation and scroll down to Joomla 2-5 Specifics - JB Library.

But still, I would better suggest not to use it together.
  • Zuzuzu's Avatar
  • Zuzuzu
  • LIfetime Developer - Big Bamboo
  • 1925 posts
  • 107 Thanks
  • Karma: 67
The administrator has disabled public write access.
Thanks for the follow up. I had done as you suggested - earlier google version, and it took... after a few minutes.
  • blueshift's Avatar
  • blueshift
  • 6 Month Developer
  • 2579 posts
  • 78 Thanks
  • Karma: 26
The administrator has disabled public write access.
So all ok now. Great
  • Zuzuzu's Avatar
  • Zuzuzu
  • LIfetime Developer - Big Bamboo
  • 1925 posts
  • 107 Thanks
  • Karma: 67
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers