Support Forum

  • Page:
  • 1
  • 2

JB Type - Using in Modules

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

OK, I think I need to slow down on web dev work as the simple things just are not working any more.

Sorry to have to ask, but i am having trouble getting JB Type to work in either K2 items or in a module.

In a K2 Item, see here, I have entered the text This zip file contains a help text file with full installation instructions. but as you can see it does not show up.

Also, I have a HTML module published in the Footer Position, with another JB Type which also is not showing up.

If I check the page using FireBug, i can see
<span class="info"> This zip file contains a help text file with full installation instructions. </span>
which to me seems to be ok.

JB Type is installed :) and I have tried both coquette and orange stickers.

JB Library is also installed and enabled.

Any ideas ?
  • K2Joom's Avatar
  • K2Joom
  • 12 Month basic
  • 136 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Hey there,

You probably aren't seeing the desired effect since there might be a template style for a class info which might be clashing with the JB Type added styles.
If you have a link to share I could help figure out what was happening.

Cheers,
Jason.
  • Jason D's Avatar
  • Jason D
  • 6 Month Developer
  • 2957 posts
  • 12 Thanks
  • Karma: 75
The administrator has disabled public write access.
I'll be releasing an update to JB Type this week which will have more unique class names in order to avoid such clashes.
  • Jason D's Avatar
  • Jason D
  • 6 Month Developer
  • 2957 posts
  • 12 Thanks
  • Karma: 75
The administrator has disabled public write access.
Hi Jason,
Here is a link, same as in first post: k2joom.com/index.php?option=com_k2&view=item&id=96:k2-comments-auto-notification-11&Itemid=4
  • K2Joom's Avatar
  • K2Joom
  • 12 Month basic
  • 136 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Actually I think this is a limitation in Joomla not being able to render plugins in modules. We have this has an update because there is a work wround and I think we might try to push it forward on the todo list.

Will let you know :)

Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
I have also just setup two pages, one for styles and one for typography to list what is set in my templates.

Again, adding in JB types still not working, Check k2joom.com and select Typo when hovering over the About menu.
  • K2Joom's Avatar
  • K2Joom
  • 12 Month basic
  • 136 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Looks like that is still the plugin rendering in a module. Ill get Jason to look at that today.

Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Actually while I think of this its basically an issue with Joomla that doesnt render plugin syntax in a module. Joomla 1.0 used to be able to do this but for some reason they removed the functionality in j1.5.

There are some modules that render plugins such as the UCD from Joomlaworks but I dont know of any others that do it.

Thanks Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
I removed the instance I had of the plugin in the Custom HTML for footer
  • K2Joom's Avatar
  • K2Joom
  • 12 Month basic
  • 136 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Hi,

I've just installed the JB Type plugin in my site with Wallpaper template. Probably I'm doing something wrong.
Do I type the {jb_note} and {/jb_note} in the editor or in the html ?
  • Pamela Manuhutu's Avatar
  • Pamela Manuhutu
  • Previous Member
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
Pamela Manuhutu wrote:
Hi,

I've just installed the JB Type plugin in my site with Wallpaper template. Probably I'm doing something wrong.
Do I type the {jb_note} and {/jb_note} in the editor or in the html ?

You should be able to do it just in the editor.
  • K2Joom's Avatar
  • K2Joom
  • 12 Month basic
  • 136 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Jason DSouza wrote:
I'll be releasing an update to JB Type this week which will have more unique class names in order to avoid such clashes.

Hi Jason, was a new update released for JB Type?

Thanks.
  • K2Joom's Avatar
  • K2Joom
  • 12 Month basic
  • 136 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
I tried, without succes, in the banner.
livheesbeen.nl/
  • Pamela Manuhutu's Avatar
  • Pamela Manuhutu
  • Previous Member
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Pamela,

I don't think the JB-type code is going to work from within a module, as plugins generally don't in Joomla, as Anthony mentioned.

However, you also have to be aware that the slideshow module will be stripping out the mark-up for JB-type as well. In the short-term, it is probably easier to just link to the JB-type icons from your article code, as that will work from within a module. Then just make sure to allow img tags in the slideshow.
  • Seth's Avatar
  • Seth
  • Moderator
  • 8358 posts
  • 225 Thanks
  • Karma: 202
The administrator has disabled public write access.
Aha...I get it. Thanks!
  • Pamela Manuhutu's Avatar
  • Pamela Manuhutu
  • Previous Member
  • 7 posts
  • Karma: 0
The administrator has disabled public write access.
No problem Pamela.
  • Seth's Avatar
  • Seth
  • Moderator
  • 8358 posts
  • 225 Thanks
  • Karma: 202
The administrator has disabled public write access.
Hey Simon,

An update has not been released as yet but I will push it up the list. The aim is to get it to work in modules.

Cheers,
Jason.
  • Jason D's Avatar
  • Jason D
  • 6 Month Developer
  • 2957 posts
  • 12 Thanks
  • Karma: 75
The administrator has disabled public write access.
Thanks Jason, no problem.

Sure you can understand that it would be great to have this working.

I shall remain patient.
  • K2Joom's Avatar
  • K2Joom
  • 12 Month basic
  • 136 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Sorry to bring this up again.
Recently the conversation concentrated on JB in Modules, as the title states, but initially it was also stated it would not work for me in K2 items.
Anyways, whilst looking through some of my K2 Items, I noticed an Orange Sticker!!!

JB worked . . . but wait . . . How?

I had searched for "installation" using the search form in the CPanel position.
This pulled up these results which show the Sticker.
http://aviary.com/creation?fguid=33c2b800-61ef-102d-92fe-0030488e168c


When I go to the actual item, then it has gone again.

http://aviary.com/creation?fguid=7448c324-61ef-102d-92fe-0030488e168c

From the page showing the sticker, I can see the HTML as:
<span class="info"> This zip file contains a help text file with full installation instructions. </span>

With the style pointing to .item and the css as:
.info {
background:transparent url(/plugins/content/jbtype/images/orangesticker/info.png) no-repeat scroll left center;
display:block;
padding:20px 0 20px 60px;
}

Interestingly, the css sheet is pointing to the generated page and a aquick view source, shows the above css embeded in the page:
<style type="text/css">
    <!--
.info {background: url(/plugins/content/jbtype/images/orangesticker/info.png) no-repeat left center;padding: 20px 0 20px 60px;display:block;} 

    -->
  </style>

So now, when I go view the item, the HTML is the same as above but the CSS is not linked at all.
It just points to k2joom.com/templates/avanti/css/template_css.css which does not contain the element .info

Is this a problem where by JB Type is not embedding the styling into the actual item page, or perhaps I should look at moving all the images and CSS associated with JB Type into the avanti template.

Maybe this is just an issue with working with k2?

So I pop over to your JB Type Page as that is showing all the types available.
Check the source code and all the associated styles are embeded in the head.

I kind of suspect and you might be able to clarify, but I dont think JB Type is linking up correctly to K2 items.

What do you think?
  • K2Joom's Avatar
  • K2Joom
  • 12 Month basic
  • 136 posts
  • 1 Thanks
  • Karma: 0
Last Edit: 12 years 6 months ago by K2Joom.
The administrator has disabled public write access.
Do you think it would work to take the styles from the plugins/content/jbtype/styles.php, reformat it to just CSS and then place that in the template_css.css? and also move the image folder.
  • K2Joom's Avatar
  • K2Joom
  • 12 Month basic
  • 136 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers