Must Read: New Unified System is officially live Must Read     |   6 Templates Updated (27 April 2018) Read more

Support Forum

Please note that this forum is only available to you in read only mode. In order to contribute to this conversation you will need to renew your subscription.

error on layout change

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi - I'm sometimes getting an error when I try to save layout changes in template styles.

Basically it's saying cannot save changes and “status”:500, “statusText”:”Internal Server Error”

I'm also getting this in the template editor when I set error messages to max:

Notice: Array to string conversion in /home/swanseainbloomco/public_html/libraries/joomla/filter/input.php on line 282

The site is swanseainbloom.co.uk J 3.7.4

Anyone any ideas?

Thanks

Ian
  • ianpanorton's Avatar
  • ianpanorton
  • 6 Month Developer
  • 1258 posts
  • 3 Thanks
  • Karma: 7
The administrator has disabled public write access.
The database is up to date, and no errors showing in ACL...
  • ianpanorton's Avatar
  • ianpanorton
  • 6 Month Developer
  • 1258 posts
  • 3 Thanks
  • Karma: 7
The administrator has disabled public write access.
Hi Ian,

"when I try to save layout changes in template styles."

What setting are you changing?

And what are you adding to the setting?

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul - thanks for getting back to me.

I'm changing widths of grid items - grid 5 from three to five columns and grid 8 from nine to seven.

It seems to be occasional. Right now it's working, but sometimes not. Also, remember the problem I was having of menu items defaulting to trashed? That came back today too.

I quit Safari and reopened and that seemed to fix this one again, but the whole site seems a bit unstable. I can't get a couple of custom css modules to publish right now. Probably user error as usual, I'll have another look at this one tomorrow.

I've checked PHP memory allocation and I have 256 MB - checked in cPanel and with the host.

There are some other funny things too - New menu item, jobs to do this month, is not following the li active colour in custom css. All the other menu headings are working fine, except in the footer menu, where none of them work.

It's all probably user error, but it would be good to know where I'm going wrong :-)

Thanks

Ian
  • ianpanorton's Avatar
  • ianpanorton
  • 6 Month Developer
  • 1258 posts
  • 3 Thanks
  • Karma: 7
The administrator has disabled public write access.
Hi Ian,

Something definitely wrong somewhere with the link

www.swanseainbloom.co.uk/garden-jobs/things-to-do-in-august

showing the home as the active link element

Is the database up to date?

extensions > manage > database
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
" can't get a couple of custom css modules to publish right now."

Are you referring to custom html modules?
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Do you have url management extensions installed? e.g. like shf404sef

Do you have any caching enabled on the site?

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
Hi Paul - thanks for getting back to me.

I am using SH404SEF - and the problem was with this.

I meant custom html modules of course, not css. After a bit of Googling I found this - which worked for me:

'First ensure that the module is set to display on the specific menu. Then:

In Joomla's menu list, find the Itemid of the menu item that displays the page. It will be listed in the last column labelled ID. You will need this ID later in the last step.

Open the sh404SEF URL manager and locate the SEF url for that page which is not displaying the module. You will notice that the SEF url will have at least 1 duplicate URL for this item. Click on the this number to open the Duplicates Manager.

There should be a native URL such as (index.php?option=com_k2&Itemid=345&id=214&lang=en&view=item) that contains the Itemid you found in step 1 above.

You need to make it the Main url by clicking on the Make Main button.'

Hope this may help somebody else...

Thanks again,

Ian
  • ianpanorton's Avatar
  • ianpanorton
  • 6 Month Developer
  • 1258 posts
  • 3 Thanks
  • Karma: 7
The administrator has disabled public write access.
The following user(s) said Thank You: paulus103
umm groan with sh404set this really needs to be managed very carefully and treated with extreme respect

This can screw up module assignment requiring a purge of the relevant link
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
On sites that have shf404sef I try to avoid changing any setting after configuring it when site is launched

If I ever need to change urls or anything like that I back up first using akeeba pro then I can go back if something really terrible happens

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.
I'd use and configure sh404sef when site is completely finished - leave it to last :)

Thanks for your post

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45248 posts
  • 2106 Thanks
  • Karma: 603
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers