Support Forum

  • Page:
  • 1
  • 2

Fitvids 1.0.4 .. now my videos are broken

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

  • SteinerPDP's Avatar
  • SteinerPDP
  • 12 Month Developer
  • 397 posts
  • 3 Thanks
  • Karma: 2
Last Edit: 9 years 9 months ago by SteinerPDP.
The administrator has disabled public write access.
I have the same problem in that they don't show up at all. I went in, double checked everything and it is all set up correctly, just nothing shows.

rwr.rxsitedesigns.com
  • ryanshawnoshea's Avatar
  • ryanshawnoshea
  • 6 Month Developer
  • 10 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Ryan,

Your video seems to be functioning on my end. Or did you change versions?

I can however replicate the issue here locally and will get Anderson to fix this shortly.

Thanks for your patience.

Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
NB: all browsers are behaving in the same way, incl. IE8 and the Android.
  • SteinerPDP's Avatar
  • SteinerPDP
  • 12 Month Developer
  • 397 posts
  • 3 Thanks
  • Karma: 2
The administrator has disabled public write access.
A fix for this is in progress. Thanks for your patience folks :)
  • Seth's Avatar
  • Seth
  • Moderator
  • 8358 posts
  • 225 Thanks
  • Karma: 202
The administrator has disabled public write access.
np .. ETA?
  • SteinerPDP's Avatar
  • SteinerPDP
  • 12 Month Developer
  • 397 posts
  • 3 Thanks
  • Karma: 2
The administrator has disabled public write access.
Yes, I did a change. Anderson Martins suggested I change the values on allvideos plugin to a specific size. So i took auto off of height and width and put a fixed value of 1200 by 900 for the max sizes and it works fine!
  • ryanshawnoshea's Avatar
  • ryanshawnoshea
  • 6 Month Developer
  • 10 posts
  • Karma: 0
The administrator has disabled public write access.
Hi Phillip - can you try Ryan's solution above? Seems that Andersons fix may be correct but needs a different implementation. Ill take a look at Anderson notes and update the notes accordingly.

Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
changed avVideo settings from auto to 1200x900.

The settings are a work-around for videos displayed in the content. It does not look right See borders of video in www.dalinyebo.com/completed-projects-list/item/379-greenenergypark%E2%84%A2-design#introduction-video

For K2 media, they also now work, but don't display correctly (the height is limited to 150px, and I cannot figure out what causes that limitation. See e.g.
- www.greenenergypark.co.za/component/k2/item/212-poverty-alleviation
or
- www.dalinyebo.com/news/item/456-new-green-materials

Thank you.
Philipp
  • SteinerPDP's Avatar
  • SteinerPDP
  • 12 Month Developer
  • 397 posts
  • 3 Thanks
  • Karma: 2
The administrator has disabled public write access.
Hi Steiner,

Sorry for delay, but I was checking all fitvids code, and could not find any problem related to this issue. But checking your page, I could see that you have this code: jQuery("#MainContent").fitVids();

it is generated by Fitvids plugin, but taking a look on html code, you don't have '#MainContent', you have a '#mainContent' container... just a typo in your configurations for Fitvids.

Could you check if changing that Fitvid selector settings fix that?

Thanks
  • Anderson Grüdtner Martins's Avatar
  • Anderson Grüdtner Martins
  • LIfetime Developer - Big Bamboo
  • 94 posts
  • 10 Thanks
  • Karma: 8
The administrator has disabled public write access.
Hi Anderson,

changed AllVideos sizes to auto/auto.
changed Fitvids to #MainContent

All videos now display at 150px, but not at their full height:
- www.dalinyebo.com/completed-projects-list/item/379-greenenergypark%E2%84%A2-design#introduction-video
- www.greenenergypark.co.za/component/k2/item/212-poverty-alleviation
- www.dalinyebo.com/news/item/456-new-green-materials

Suggestion:
- Change typo in your instructions.
- Provide more instructions: e.g. can you have more than one 'selector' and if so, do they need to be separated by commas or spaces or line breaks?
Fullscreen301020120910.jpg


Regards,
Philipp
  • SteinerPDP's Avatar
  • SteinerPDP
  • 12 Month Developer
  • 397 posts
  • 3 Thanks
  • Karma: 2
The administrator has disabled public write access.
#mainContent is the correct selector - not #MainContent.

You can just separate selectors by a comma but #mainContent will wrap anything in the main content area.

The plugin ships with .container by default which covers our templates fine.

I updated the Fitvid instructions today to remove the need for auto and for the user to add a default maximum width or maximum height.

Thanks
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Thanks for the explanations.

set to it back to .container
set AllVideo DEFAULT to 640x 480

video still displays at 150 px max hight!

Code from "Inspect Element"
element.style {
max-width: 640px;
max-height: 150px;
}

www.greenenergypark.co.za/component/k2/item/212-poverty-alleviation
  • SteinerPDP's Avatar
  • SteinerPDP
  • 12 Month Developer
  • 397 posts
  • 3 Thanks
  • Karma: 2
Last Edit: 9 years 9 months ago by SteinerPDP.
The administrator has disabled public write access.
Hi Steiner,

Weird, could you open a ticket with admin permissions? I need to check uploading some test versions, because It couldn't be related to our Fitvids extension. But I want to check, because it works in my tests.

I was debugging setting a breakpoint right on the first line of our JS file, before ALL calculations or modifications for videos, and the container is loaded by Allvideos already having that 150px for height. So we can not calculate the height you desire if Allvideos is setting a wrong height.

I think I can help with admin access.

Thanks
  • Anderson Grüdtner Martins's Avatar
  • Anderson Grüdtner Martins
  • LIfetime Developer - Big Bamboo
  • 94 posts
  • 10 Thanks
  • Karma: 8
The administrator has disabled public write access.
see U0058Y1F34
  • SteinerPDP's Avatar
  • SteinerPDP
  • 12 Month Developer
  • 397 posts
  • 3 Thanks
  • Karma: 2
The administrator has disabled public write access.
Fix coming in 1.0.5 thanks
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
tx .. any ideas on the timing?
  • SteinerPDP's Avatar
  • SteinerPDP
  • 12 Month Developer
  • 397 posts
  • 3 Thanks
  • Karma: 2
The administrator has disabled public write access.
I believe this may have been dealt with in your ticket. I need to check with Anderson in regards to the fix but as mentioned int he ticket there was some unique case in your cicumstance.
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.
Anthony,

I can't figure out from the ticket what was unique. At the moment the plugin works on one site where the fix was made (which I understand will go into 1.0.5), but does not on the other, when I use the same settings.

You have changed your instructions to add a max px setting into AllVideos. When I do this (i.e. change the AllVideo DEFAULT), then videos start working on the second site, but there are still issues. The only one that looks good is the inside a content. The ones added as a K2 media, don't look good in the Zentool nor in the content. I chose as max dimension 1020x720. See links in the ticket.

Thanks,
Philipp
  • SteinerPDP's Avatar
  • SteinerPDP
  • 12 Month Developer
  • 397 posts
  • 3 Thanks
  • Karma: 2
The administrator has disabled public write access.
I tend to agree actually - not sure why it was unique.

However yesterday we had three mods looking at your site after Zuzana implemented the fix. And they could all see videos working properly.

I'll reopen the ticket for Zuzana to look again.

Anthony
  • Anthony Olsen's Avatar
  • Anthony Olsen
  • LIfetime Developer - Big Bamboo
  • 23925 posts
  • 788 Thanks
  • Karma: 433
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers