JoomlaBamboo is now part of JoomlArt Read more

Support Forum

  • Page:
  • 1

introtext image not displaying

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

i am using zentools2 to display hotel rooms and have a book now button in the introtext. it shows the image assigned in the joomla introimage and it shows the introtext but not the image i put in before the read more. if i set a btn class that works but the client wants the button we designed. i do not have strip tags turned on and i also included the img tag in the comma separated list to be sure but it still won't show and is stripping the image out.

i would really like to use the button but i can't seem to find the right workaround. i had expected it would show the image if i didn't strip tags.

You can see an example on the last image in the screenshots below.

How can i resolve this? right now i just have the btn class
ss_button_no_render.png


ss_button_no_render2.png


ss_button_no_render3.png


ss_button_no_render4.png
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 388 posts
  • 8 Thanks
  • Karma: 2
Last Edit: 2 weeks 4 days ago by candyce.
The administrator has disabled public write access.
Have you tried enabling strip tags and then adding img to allowed tags?

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45153 posts
  • 2098 Thanks
  • Karma: 604
The administrator has disabled public write access.
yes i did try using strip tag and putting just the tags that i really needed and still it didn't work.
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 388 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
Right so you are using the image from the image and links tab
and from the intro text you want text and image to display?

I'll have to try this myself so just want to be sure I'm testing the right setup of the module
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45153 posts
  • 2098 Thanks
  • Karma: 604
The administrator has disabled public write access.
yes that is correct, the article image from image and links and then i want the image in the introtext to display. i do have a read more break in there and i am not truncating the intro by x number of characters.
if you want me to file a ticket i can do that. i haven't had this problem before but then i usually use k2. i actually entertained k2 after the fact but the import of content went badly and i was stuck with a bunch of json errors. i don't have time to redo all the content so i am sticking to joomla native article.
  • candyce's Avatar
  • candyce
  • 12 Month Developer
  • 388 posts
  • 8 Thanks
  • Karma: 2
The administrator has disabled public write access.
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45153 posts
  • 2098 Thanks
  • Karma: 604
The administrator has disabled public write access.
I've set the links to point to bbc manually in the article code

and I didn't change the image links when clicked

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 45153 posts
  • 2098 Thanks
  • Karma: 604
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers