Take 50% off our developer subscriptions with the coupon "nifty50" Custom Web Development Services

Support Forum

migrating from Joomla 2.5 to 3+ and Colourshift (original)

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Hi guys i have to upgrade a site based on colourshift (using joomla 2.5) to joomla 3 because my host has started using PHP v7 and its causing errors with the database.
two or three questions if I could ...
is the original colourshift compatible with Joomla 3 ? so that i could upgrade to joomla 3 without a problem? (Ive updated other components)
Are the zen grid framework v2.3.1 and zen tools v1.10.6 compatible with 3+ or would i have to update them first?
if the previous questions arnt possible can i used colourshift 2 wih the exisiting database and content?
many thanks in advance
glenn
  • Glenn Shaw's Avatar
  • Glenn Shaw
  • 3 Month Basic
  • 75 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Hi Glenn,

Id strongly suggest migrating the template to the newest version

bambootheme.com/showcase/sep16/

this was released last year

This uses the zen grid 5 framework as well as a newer version of zentools called zentools2

You could keep using zentools v1 but you would need to use the latest version of that to be compatible with php7

The template version you have is not compatible with joomla 3

The errors I'd expect to see would be fatal php errors coming from both template and zentools
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 44730 posts
  • 2060 Thanks
  • Karma: 600
The administrator has disabled public write access.
Regarding

"if the previous questions arnt possible can i used colourshift 2 wih the exisiting database and content?"

You may run into problems with the database collation but this is a Joomla issue rather than template or extension

I'd strongly suggest taking a copy of the site and migrating that version of the site
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 44730 posts
  • 2060 Thanks
  • Karma: 600
The administrator has disabled public write access.
What I would also suggest is if possible moving to php 5.6 first rather than php7

You could well find that extensions are compatible with the latest Joomla 3 version = 3.8.2 but are not compatible with php7

Once you have the site migrated and stable on 5.6 I would then try moving to php7
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 44730 posts
  • 2060 Thanks
  • Karma: 600
The administrator has disabled public write access.
Moving on to content

The standard Joomla and zentools content should be fine once everything is updated

You will have to move stuff around position wise as position names will be different
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 44730 posts
  • 2060 Thanks
  • Karma: 600
The administrator has disabled public write access.
If you need clarification on any of above please ask

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 44730 posts
  • 2060 Thanks
  • Karma: 600
The administrator has disabled public write access.
Ive no problems doing this Paul, especially if its going to be easier, Ive been messing with this for nearly 2 weeks now updating various components etc and i am running into php errors etc
if i do upgrade woukld this be joomla 4 compatable or am I going to run into the same problems ?
  • Glenn Shaw's Avatar
  • Glenn Shaw
  • 3 Month Basic
  • 75 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Ive already migrated the site (setup on wamp locally so the original is untouched) once ive updated the components etc what else would need to be done ??
  • Glenn Shaw's Avatar
  • Glenn Shaw
  • 3 Month Basic
  • 75 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Im working on that basis on my local wamp setup. do you mean with the new template version ?
  • Glenn Shaw's Avatar
  • Glenn Shaw
  • 3 Month Basic
  • 75 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
no problem doing that the site needs updating a little anyways ..
sorry for so many questions but as I mentioned Ive spent 2 weeks trying to sort this, got so far and then hit the proverbial brick wall lol
many thanks for all your help and advice Paul.
  • Glenn Shaw's Avatar
  • Glenn Shaw
  • 3 Month Basic
  • 75 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Using the existing framework (zgfv2) you have will get php errors

Using zentools 1.14.1 is php7 compatible so that will work without having to create new modules

Regarding Joomla4 it is still up in the air as I understand it
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 44730 posts
  • 2060 Thanks
  • Karma: 600
The administrator has disabled public write access.
With a migration you would remove the extensions that are not compatible with the new Joomla version

so this would be components, templates, plugins and modules

You'd also disable the remember me plugin
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 44730 posts
  • 2060 Thanks
  • Karma: 600
The administrator has disabled public write access.
What php errors are you getting?

a json error is quite common

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 44730 posts
  • 2060 Thanks
  • Karma: 600
The administrator has disabled public write access.
These videos might help

www.siteground.com/tutorials/joomla-video/upgrade-introduction/
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 44730 posts
  • 2060 Thanks
  • Karma: 600
The administrator has disabled public write access.
Ok Paul, so from what i understand, I
update, remove or disable components etc (already done actually)
save the updated database,
buy the colourshift 2 template, install it on my local wamp server,
test the installation and rectify any problems with the layout etc on PHP v5+
then test it on PHP 7+
then upload to my main host, is that correct?
thanks
glenn
  • Glenn Shaw's Avatar
  • Glenn Shaw
  • 3 Month Basic
  • 75 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
paulus103 wrote:
With a migration you would remove the extensions that are not compatible with the new Joomla version

so this would be components, templates, plugins and modules

You'd also disable the remember me plugin

what does the remember me plugin do exactly and why would i need to delete it?
  • Glenn Shaw's Avatar
  • Glenn Shaw
  • 3 Month Basic
  • 75 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Can't entirely remember

Please don't delete it just disable it in plugin manager

I know it causes problems with the migration process - It has been a while since I migrated a J2.5 and the update process was much improved with the most recent update

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 44730 posts
  • 2060 Thanks
  • Karma: 600
The administrator has disabled public write access.
paulus103 wrote:
Can't entirely remember

Please don't delete it just disable it in plugin manager

I know it causes problems with the migration process - It has been a while since I migrated a J2.5 and the update process was much improved with the most recent update

Cheers
Paul
np Paul, I've disabled it earlier anyways, but thanks for the heads up.
  • Glenn Shaw's Avatar
  • Glenn Shaw
  • 3 Month Basic
  • 75 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.
Are you still having problems with the migration?

Cheers
Paul
  • paulus103's Avatar
  • paulus103
  • Moderator
  • 44730 posts
  • 2060 Thanks
  • Karma: 600
The administrator has disabled public write access.
paulus103 wrote:
Are you still having problems with the migration?

Cheers
Paul

well ive updated, disabled or removed items as required. Just need to talk to my customer as regards the update so i'll let you know paul.
So do i install the newer template and then update joomla to version 3?
(btw i read somewhere that when updating you have to go to 3.51 first, is that correct?)
many thanks for all your help and advice though
glenn
  • Glenn Shaw's Avatar
  • Glenn Shaw
  • 3 Month Basic
  • 75 posts
  • 1 Thanks
  • Karma: 0
The administrator has disabled public write access.

zentoolsIf you use Zentools please post a review at the Joomla! Extensions Directory.

Happy Campers